Issue 9725

Title
Prevent to do twice sync_inventory_moves on shipment_out workflow
Priority
bug
Status
resolved
Nosy list
ced, mrichez, reviewbot, roundup-bot, tbruyere
Assigned to
mrichez
Keywords
review

Created on 2020-10-16.09:44:34 by mrichez, last changed yesterday by roundup-bot.

Files

File name Uploaded Type Details
2020-10-15_13-04.png mrichez, 2020-10-16.09:44:34 image/png view

Messages

New changeset 3eec00b60260 by Cédric Krier in branch 'default':
Test OverShipmentWarning exception on pack
https://hg.tryton.org/tryton-env/rev/3eec00b60260
New changeset db85bf48d960 by Cédric Krier in branch 'default':
Test OverShipmentWarning exception on pack
https://hg.tryton.org/modules/sale_shipment_tolerance/rev/db85bf48d960
New changeset 580ac0596323 by Cédric Krier in branch 'default':
Do not assign on pick and do not synchronize on pack
https://hg.tryton.org/tryton-env/rev/580ac0596323
New changeset 02b9da5cf94b by Maxime Richez in branch 'default':
Do not assign on pick and do not synchronize on pack
https://hg.tryton.org/modules/stock/rev/02b9da5cf94b
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2020-10-16.10:45:01
For me the problem is not that both method do the same but that:

- pick assign the outgoing moves so it prevent editing them (which was the goal of adding the picked state)
- pack synchronize again the outgoing move so if by mistake it could try to update already assigned outgoing moves.
Author: [hidden] (mrichez)
Date: 2020-10-16.09:44:34
Pick and pack methods in shipment_out workflow are doing the same actions. So when doing pack on updated inventory moves that are already done by the pick method, sync_inventory_moves raise an error because moves are not in draft state.
History
Date User Action Args
2020-10-24 22:40:36roundup-botsetmessages: + msg61372
2020-10-24 22:40:32roundup-botsetmessages: + msg61371
2020-10-21 23:49:19roundup-botsetmessages: + msg61142
2020-10-21 23:49:15roundup-botsetmessages: + msg61141
nosy: + roundup-bot
status: testing -> resolved
2020-10-16 10:45:01cedsetnosy: + ced
messages: + msg60983
2020-10-16 10:31:59reviewbotsetnosy: + reviewbot
messages: + msg60982
2020-10-16 10:31:58reviewbotsetreviews: 304481002
keyword: + review
2020-10-16 10:13:37mrichezsetstatus: in-progress -> testing
2020-10-16 09:44:34mrichezcreate

Showing 10 items. Show all history (warning: this could be VERY long)