Tryton - Issues

 

Issue9525

Title Stripe payment shoul go back to processing instead of failed
Priority bug Status resolved
Superseder Nosy List ced, reviewbot, roundup-bot
Type behavior Components account_payment, account_payment_clearing, account_payment_stripe
Assigned To ced Keywords review
Reviews 302001002
View: 302001002

Created on 2020-08-07.13:16:30 by ced, last changed by roundup-bot.

Messages
New changeset 1a778b5984d6 by Cédric Krier in branch 'default':
Allow going back to processing state
https://hg.tryton.org/tryton-env/rev/1a778b5984d6
New changeset f5a1e9c7b140 by Cédric Krier in branch 'default':
Allow going back to processing state
https://hg.tryton.org/modules/account_payment_stripe/rev/f5a1e9c7b140
New changeset 1b4c816e37ae by Cédric Krier in branch 'default':
Allow going back to processing state
https://hg.tryton.org/modules/account_payment_clearing/rev/1b4c816e37ae
New changeset af3d1b7a5b56 by Cédric Krier in branch 'default':
Allow going back to processing state
https://hg.tryton.org/modules/account_payment/rev/af3d1b7a5b56
review302001002 updated at https://codereview.tryton.org/302001002/#ps302011002
review302001002 updated at https://codereview.tryton.org/302001002/#ps323821002
msg59644 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2020-08-07.13:16:30
We found that sometimes Stripe send twice the succeeded event for a payment. The problem is that the second times, as the payment is already succeeded, Tryton set it first to failed and back to succeeded. This is to ensure that the clearing moves are up to date with the new amounts.
The problem comes if you plug some workflow on the failure of a payment (like canceling an order etc.).
I think we should not use the failed state to update succeeded payment but we should go back to processing.
History
Date User Action Args
2020-08-29 18:18:33roundup-botsetmessages: + msg59862
2020-08-29 18:18:27roundup-botsetmessages: + msg59861
2020-08-29 18:18:21roundup-botsetmessages: + msg59860
2020-08-29 18:18:14roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg59859
2020-08-10 13:50:10reviewbotsetmessages: + msg59666
2020-08-07 13:22:11reviewbotsetnosy: + reviewbot
messages: + msg59645
2020-08-07 13:19:27cedsetstatus: in-progress -> testing
reviews: 302001002
keyword: + review
2020-08-07 13:16:30cedcreate

Showing 10 items. Show all history (warning: this could be VERY long)