Tryton - Issues

 

Issue9491

Title reconcile error with statement
Priority bug Status resolved
Superseder Nosy List ced, reviewbot, roundup-bot, semarie
Type crash Components trytond
Assigned To Keywords review
Reviews 321961002
View: 321961002

Created on 2020-07-21.14:08:25 by semarie, last changed by roundup-bot.

Messages
New changeset 5e6a39c36646 by C├ędric Krier in branch 'default':
Do not add id_ to checked wizard ids if not set
https://hg.tryton.org/tryton-env/rev/5e6a39c36646
New changeset 775245f3903c by Sebastien Marie in branch 'default':
Do not add id_ to checked wizard ids if not set
https://hg.tryton.org/trytond/rev/775245f3903c
review321961002 updated at https://codereview.tryton.org/321961002/#ps314141002
msg59762 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2020-08-17.10:07:14
I think it is because we should not add active_id ('id_') to the list of ids to read if it is None.
msg59761 (view) Author: [hidden] (semarie) Date: 2020-08-17.09:25:17
I finally bisect it.

The first commit that expose the problem is d597bcd58c45 : "Add model, record and records attribute on Wizard" related to issue9421
msg59401 (view) Author: [hidden] (semarie) Date: 2020-07-21.14:08:24
With tip, I got the following backtrace when I reconcile (via button) a validated statement:

Traceback (most recent call last):
  File "/trytond/wsgi.py", line 109, in dispatch_request
    return endpoint(request, **request.view_args)
  File "/trytond/protocols/dispatcher.py", line 47, in rpc
    return methods.get(request.rpc_method, _dispatch)(
  File "/trytond/wsgi.py", line 77, in auth_required
    return wrapped(*args, **kwargs)
  File "/trytond/protocols/wrappers.py", line 131, in wrapper
    return func(request, pool, *args, **kwargs)
  File "/trytond/protocols/dispatcher.py", line 181, in _dispatch
    result = rpc.result(meth(*c_args, **c_kwargs))
  File "/trytond/wizard/wizard.py", line 306, in execute
    cls.check_access()
  File "/trytond/wizard/wizard.py", line 268, in check_access
    Model.read(ids, ['id'])
  File "/trytond/model/modelsql.py", line 752, in read
    red_sql = reduce_ids(table.id, sub_ids)
  File "/trytond/tools/misc.py", line 102, in reduce_ids
    ids = list(map(int, ids))
TypeError: int() argument must be a string, a bytes-like object or a number, not 'NoneType'

Fault: int() argument must be a string, a bytes-like object or a number, not 'NoneType'
History
Date User Action Args
2020-08-18 09:47:50roundup-botsetmessages: + msg59772
2020-08-18 09:47:47roundup-botsetstatus: chatting -> resolved
nosy: + roundup-bot
messages: + msg59771
2020-08-17 11:30:48reviewbotsetnosy: + reviewbot
messages: + msg59763
2020-08-17 11:24:03semariesetreviews: 321961002
component: + trytond, - account_statement
keyword: + review
2020-08-17 10:07:14cedsetnosy: + ced
messages: + msg59762
2020-08-17 09:25:17semariesetstatus: unread -> chatting
messages: + msg59761
2020-07-21 14:08:25semariecreate

Showing 10 items. Show all history (warning: this could be VERY long)