Tryton - Issues

 

Issue9455

Title Datepicker calendar is hidden inside form
Priority bug Status resolved
Superseder Nosy List ced, edbo, perilla, pokoli, reviewbot, roundup-bot
Type behavior Components sao
Assigned To ced Keywords review
Reviews 327751002
View: 327751002

Created on 2020-07-03.15:36:54 by perilla, last changed by roundup-bot.

Files
File name Uploaded Type Edit Remove
another-date-picker.png perilla, 2020-07-03.15:36:53 image/png
Messages
New changeset 371a3659cd5d by Cédric Krier in branch 'default':
Do not monkey patch datetimepicker if not loaded
https://hg.tryton.org/tryton-env/rev/371a3659cd5d
New changeset 41ebb700348d by Cédric Krier in branch 'default':
Do not monkey patch datetimepicker if not loaded
https://hg.tryton.org/sao/rev/41ebb700348d
New changeset 8339ba170bb8 by Cédric Krier in branch 'default':
Use tempusdominus and Popper for date time picker
https://hg.tryton.org/tryton-env/rev/8339ba170bb8
New changeset ebf7626f0631 by Cédric Krier in branch 'default':
Use tempusdominus and Popper for date time picker
https://hg.tryton.org/sao/rev/ebf7626f0631
review327751002 updated at https://codereview.tryton.org/327751002/#ps300311002
review327751002 updated at https://codereview.tryton.org/327751002/#ps315791002
review327751002 updated at https://codereview.tryton.org/327751002/#ps306191002
msg59581 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2020-08-02.13:44:26
Here is review327751002 which uses tempusdominus and Popper which should solve all those kind of issues.
msg59580 (view) Author: [hidden] (edbo) Date: 2020-08-01.11:59:44
I don't encounter this issue with 5.4. Try msg58947 on both demo5.4 and 5.6.

Digged a bit deeper:

The table is enclosed into two div's. The most upper div have a class "content-box". In version 5.4 this class doesn't have any specific CSS-rules, but 5.6 have a rule "overflow-y: auto;" and that's the problem. On version 5.6 disable it in your inspector and everything works like you would expect.
msg59577 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2020-08-01.09:30:35
This is like issue5967 again linked to https://github.com/Eonasdan/bootstrap-datetimepicker/issues/1346.
I think we should update to use the new https://github.com/tempusdominus/bootstrap-3 (which allow to define where to put the popup widget).
msg58947 (view) Author: [hidden] (perilla) Date: 2020-07-03.16:07:39
project.work on demo server 
https://streamable.com/q91nfw
msg58946 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2020-07-03.15:44:43
Could you please find a place on the oficial modules where the issue is reproducible or share the view code?
msg58945 (view) Author: [hidden] (perilla) Date: 2020-07-03.15:36:53
datepicker is not correctly shown on forms, similar to issue9316

https://streamable.com/t9981o
History
Date User Action Args
2020-09-12 10:41:41roundup-botsetmessages: + msg60081
2020-09-12 10:41:38roundup-botsetmessages: + msg60080
2020-09-12 09:58:50roundup-botsetmessages: + msg60075
2020-09-12 09:58:47roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg60074
2020-08-25 23:51:25reviewbotsetmessages: + msg59838
2020-08-03 13:24:21reviewbotsetmessages: + msg59600
2020-08-02 13:45:58reviewbotsetnosy: + reviewbot
messages: + msg59582
2020-08-02 13:44:26cedsetstatus: chatting -> testing
keyword: + review
messages: + msg59581
reviews: 327751002
assignedto: ced
type: behavior
2020-08-01 11:59:45edbosetnosy: + edbo
messages: + msg59580
2020-08-01 09:30:36cedsetnosy: + ced
messages: + msg59577

Showing 10 items. Show all history (warning: this could be VERY long)