Tryton - Issues

 

Issue8981

Title Show salable product to salesmen
Priority feature Status resolved
Superseder Nosy List ced, reviewbot, roundup-bot
Type feature request Components sale
Assigned To ced Keywords review
Reviews 258651002
View: 258651002

Created on 2020-01-10.11:25:56 by ced, last changed by roundup-bot.

Files
File name Uploaded Type Edit Remove
2020-01-10-112627_970x776_scrot.png ced, 2020-01-10.11:34:13 image/png
Messages
New changeset 4ae78e9807b9 by Cédric Krier in branch 'default':
Add salable products menu entry
https://hg.tryton.org/tryton-env/rev/4ae78e9807b9
New changeset d5bd02d543d5 by Cédric Krier in branch 'default':
Add salable products menu entry
https://hg.tryton.org/modules/sale_price_list/rev/d5bd02d543d5
New changeset ba2d7b9829a9 by Cédric Krier in branch 'default':
Add salable products menu entry
https://hg.tryton.org/modules/sale/rev/ba2d7b9829a9
New changeset db1114768795 by Cédric Krier in branch 'default':
Add salable products menu entry
https://hg.tryton.org/modules/product_price_list_dates/rev/db1114768795
review258651002 updated at https://codereview.tryton.org/258651002/#ps260781002
msg54799 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2020-01-10.11:34:13
Here is review258651002 and a screenshot of the view.
msg54797 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2020-01-10.11:25:55
Currently we have a dedicated view for the searching product from sale line. This view display the required information for the salesman like sale price, quantity, forecast etc.
The problem is that to see this view, the salesman need to create a sale order. But this is not always the desired workflow.
So I propose to have a menu entry for salable product which uses this view with a proper configurable context.
History
Date User Action Args
2020-02-23 13:55:33roundup-botsetmessages: + msg55543
2020-02-23 13:55:26roundup-botsetmessages: + msg55542
2020-02-23 13:55:21roundup-botsetmessages: + msg55541
2020-02-23 13:55:14roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg55540
2020-01-10 12:05:01reviewbotsetnosy: + reviewbot
messages: + msg54800
2020-01-10 11:34:13cedsetstatus: in-progress -> testing
reviews: 258651002
messages: + msg54799
keyword: + review
files: + 2020-01-10-112627_970x776_scrot.png
2020-01-10 11:25:56cedcreate

Showing 10 items. Show all history (warning: this could be VERY long)