Tryton - Issues

 

Issue8881

Title Invoice report file name is always printed in english
Priority bug Status resolved
Superseder Nosy List ced, pokoli, reviewbot, roundup-bot
Type behavior Components account_invoice
Assigned To pokoli Keywords review
Reviews 260621002
View: 260621002

Created on 2019-11-29.15:43:41 by pokoli, last changed by roundup-bot.

Messages
New changeset 2cdeda6767c8 by Sergi Almacellas Abellana in branch 'default':
Clear invoice report language only for rendering
https://hg.tryton.org/tryton-env/rev/2cdeda6767c8
New changeset ba1b3bfda9bb by Sergi Almacellas Abellana in branch 'default':
Clear invoice report language only for rendering
https://hg.tryton.org/modules/account_invoice/rev/ba1b3bfda9bb
review260621002 updated at https://codereview.tryton.org/260621002/#ps274581002
review260621002 updated at https://codereview.tryton.org/260621002/#ps264911002
review260621002 updated at https://codereview.tryton.org/260621002/#ps280571002
review260621002 updated at https://codereview.tryton.org/260621002/#ps274501002
msg53744 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2019-11-29.16:33:53
The problem is that the filename of the Generate file is always in English no mather what language the user has set on it's preferences. 

For other reports like sale and purchase the filename is translated to the user language, so invoice should have the same behaviour.
msg53743 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-11-29.16:12:51
I do not understand msg53741.
review260621002 updated at https://codereview.tryton.org/260621002/#ps288611006
msg53741 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2019-11-29.15:43:40
When the user has set any language diferent than English on it's preferences the invoice report has always the Invoice name while other reports (Sale and Purchase) use have the name in the user language.
History
Date User Action Args
2019-12-18 09:24:19roundup-botsetmessages: + msg54566
2019-12-18 09:24:12roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg54565
2019-12-12 13:37:01reviewbotsetmessages: + msg54467
2019-12-10 00:55:28reviewbotsetmessages: + msg54403
2019-12-03 10:25:40reviewbotsetmessages: + msg53803
2019-11-30 10:46:49reviewbotsetmessages: + msg53754
2019-11-30 10:42:53pokolisetstatus: in-progress -> testing
assignedto: pokoli
2019-11-30 09:40:52pokolisetstatus: testing -> in-progress
assignedto: pokoli -> (no value)
2019-11-29 16:33:54pokolisetmessages: + msg53744
title: Invoice report name is always printed in english -> Invoice report file name is always printed in english
2019-11-29 16:12:52cedsetnosy: + ced
messages: + msg53743

Showing 10 items. Show all history (warning: this could be VERY long)