Tryton - Issues

 

Issue8800

Title Cancelling a movement that is used to group lines results in an error.
Priority bug Status resolved
Superseder Nosy List ced, nicoe, reviewbot, roundup-bot
Type behavior Components account
Assigned To nicoe Keywords review
Reviews 260401002
View: 260401002

Created on 2019-11-06.13:04:31 by nicoe, last changed by roundup-bot.

Messages
New changeset a04915e36d18 by Nicolas ?vrard in branch 'default':
Allow to cancel move used to group lines
https://hg.tryton.org/tryton-env/rev/a04915e36d18
New changeset f72e23201548 by Nicolas ?vrard in branch 'default':
Allow to cancel move used to group lines
https://hg.tryton.org/modules/account/rev/f72e23201548
review260401002 updated at https://codereview.tryton.org/260401002/#ps272481002
review260401002 updated at https://codereview.tryton.org/260401002/#ps270531002
review260401002 updated at https://codereview.tryton.org/260401002/#ps270511002
review260401002 updated at https://codereview.tryton.org/260401002/#ps264571002
review260401002 updated at https://codereview.tryton.org/260401002/#ps260431002
review260401002 updated at https://codereview.tryton.org/260401002/#ps268391002
review260401002 updated at https://codereview.tryton.org/260401002/#ps260421002
msg53081 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-11-07.16:50:08
I think the copy of delegated lines is still a problem.
msg53080 (view) Author: [hidden] (nicoe) (Tryton committer) Date: 2019-11-07.16:44:29
In fact the issue is only that the error message does not explain correctly whats going on.
review260401002 updated at https://codereview.tryton.org/260401002/#ps252561002
review260401002 updated at https://codereview.tryton.org/260401002/#ps278141002
msg53064 (view) Author: [hidden] (nicoe) (Tryton committer) Date: 2019-11-06.13:04:30
The scenario is the following:

- Take two receivable lines and group them
- Go to the grouping movement
- Cancel the movement.

It will result in an error about the Effective Date of a Move that can not be NULL.

The origin is the fact that when we cancel, we duplicate the move and thus the 'reconciliations_delegated' field which will in turn duplicate the reconciliation and thus some lines which as we set the date to None by default and because the move line's date is a function field with a setter, the related move date is set to None which results in the error.

I am writing a patch with a test for this issue.
History
Date User Action Args
2019-11-18 12:24:55roundup-botsetmessages: + msg53304
2019-11-18 12:24:49roundup-botsetstatus: chatting -> resolved
nosy: + roundup-bot
messages: + msg53303
2019-11-15 15:06:06reviewbotsetmessages: + msg53217
2019-11-12 12:02:41reviewbotsetmessages: + msg53149
2019-11-08 19:35:37reviewbotsetmessages: + msg53110
2019-11-08 17:35:51reviewbotsetmessages: + msg53103
2019-11-08 16:07:22reviewbotsetmessages: + msg53099
2019-11-08 15:27:35reviewbotsetmessages: + msg53097
2019-11-07 17:31:19reviewbotsetmessages: + msg53083
2019-11-07 16:50:08cedsetnosy: + ced
messages: + msg53081

Showing 10 items. Show all history (warning: this could be VERY long)