Tryton - Issues

 

Issue8487

Title Validity error not shown for integer/float
Priority bug Status resolved
Superseder Nosy List ced, reviewbot, roundup-bot
Type behavior Components sao
Assigned To ced Keywords review
Reviews 255661002
View: 255661002

Created on 2019-07-11.13:51:04 by ced, last changed by roundup-bot.

Messages
New changeset fc4903828b1e by Cédric Krier in branch '5.2':
Keep showing invalid input number and set NaN on the model
https://hg.tryton.org/sao/rev/fc4903828b1e
New changeset f138f27b0d47 by Cédric Krier in branch 'default':
Keep showing invalid input number and set NaN on the model
https://hg.tryton.org/tryton-env/rev/f138f27b0d47
New changeset fe4e608239f2 by Cédric Krier in branch 'default':
Keep showing invalid input number and set NaN on the model
https://hg.tryton.org/sao/rev/fe4e608239f2
review255661002 updated at https://codereview.tryton.org/255661002/#ps269871002
msg50622 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-07-11.13:54:09
Here is review255661002 which opted to show invalid input number and use NaN as value to store on the model when invalid.
msg50621 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-07-11.13:51:03
Since r a3954339dc7e, we use two input for integer/float widget. The problem is that invalid input is no more visible on form validation (validation of a dialog) and invalid value are set on the model (so the validation error is raised too late by the server side).
History
Date User Action Args
2019-07-22 21:47:59roundup-botsetmessages: + msg50785
keyword: - backport
2019-07-17 22:52:30cedsetkeyword: + backport
2019-07-17 22:49:20roundup-botsetmessages: + msg50703
2019-07-17 22:49:15roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg50702
2019-07-11 14:05:08reviewbotsetnosy: + reviewbot
messages: + msg50623
2019-07-11 13:54:09cedsetstatus: in-progress -> testing
reviews: 255661002
messages: + msg50622
keyword: + review
2019-07-11 13:51:04cedcreate

Showing 10 items. Show all history (warning: this could be VERY long)