Tryton - Issues

 

Issue8445

Title Add option to cancel customer invoice
Priority feature Status resolved
Superseder Nosy List ced, pokoli, reviewbot, roundup-bot
Type feature request Components account_invoice
Assigned To ced Keywords review
Reviews 273511002
View: 273511002

Created on 2019-06-20.17:03:17 by ced, last changed by ced.

Messages
msg50958 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-07-30.13:08:41
Please once committed, do not open feature request but report a bug.
msg50957 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2019-07-30.13:07:14
I've been testing this new feature and after marking the "Cancel Customer Invoice" on the company I do not see the cancel button on out invoices. 

Is this the expected behaviour or is something that was missed on the implementation?
New changeset 159df1160de2 by Cédric Krier in branch 'default':
Add option to cancel customer invoice
https://hg.tryton.org/tryton-env/rev/159df1160de2
New changeset a83ef0738e63 by Cédric Krier in branch 'default':
Add option to cancel customer invoice
https://hg.tryton.org/modules/account_invoice/rev/a83ef0738e63
review273511002 updated at https://codereview.tryton.org/273511002/#ps263761002
msg50335 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-06-20.17:04:31
Here is review273511002, I opted to set the options on the company because it is mainly a company policy.
msg50334 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-06-20.17:03:17
With r 22eabf722a91, we prevent to cancel the move of customer invoice. This is because in many countries, it is forbidden to cancel an invoice but a credit note must be created.
But in some countries it is allowed so it will be better to have an option.
History
Date User Action Args
2019-07-30 13:08:41cedsetstatus: chatting -> resolved
messages: + msg50958
2019-07-30 13:07:14pokolisetstatus: resolved -> chatting
messages: + msg50957
2019-07-22 23:52:45roundup-botsetmessages: + msg50792
2019-07-22 23:52:40roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg50791
2019-06-20 17:15:37pokolisetnosy: + pokoli
2019-06-20 17:08:22reviewbotsetnosy: + reviewbot
messages: + msg50336
2019-06-20 17:04:32cedsetstatus: in-progress -> testing
reviews: 273511002
messages: + msg50335
keyword: + review
2019-06-20 17:03:17cedcreate

Showing 10 items. Show all history (warning: this could be VERY long)