Tryton - Issues

 

Issue8343

Title Can't create a new record when editable="bottom" and multiples module inherit view
Priority bug Status invalid
Superseder Nosy List ced, resteve
Type behavior Components sao
Assigned To Keywords
Reviews

Created on 2019-05-10.12:45:51 by resteve, last changed by ced.

Files
File name Uploaded Type Edit Remove
issue8343.mp4 resteve, 2019-05-28.10:10:18 video/mp4
Messages
msg49927 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-05-31.12:17:57
This is not a Tryton bug.
msg49926 (view) Author: [hidden] (resteve) Date: 2019-05-31.12:14:33
1. Can't select product in tree view, but when change to form view, I can select the product field. Product field is readonly in tree view but not in form view.

2. GTK client: Product field is editable in both views: tree and form view (with sale_line_standalone module and __setup__ [1])

3. I try to comment the code from __setup__ in SaleLine [1] and I can reproduce same behavior: product field is not editable in tree view and SAO.


[1] https://bitbucket.org/zikzakmedia/trytond-sale_line_standalone/src/6bd3656365c3af13e64d9e5d9a4d56ce9582ae14/sale.py#lines-72
msg49925 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-05-31.11:19:25
Invalidate it because it was a bug in a custom module that does not properly set depends: https://bitbucket.org/zikzakmedia/trytond-sale_line_standalone/src/6bd3656365c3af13e64d9e5d9a4d56ce9582ae14/sale.py#lines-72
msg49882 (view) Author: [hidden] (resteve) Date: 2019-05-28.10:10:18
I attach issue8343.mp4 that can be seen the msg49685
msg49686 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-05-10.13:06:06
The sentence means nothing.
Please stop putting your own priority on issue. You can never put higher then bug.
msg49685 (view) Author: [hidden] (resteve) Date: 2019-05-10.12:45:50
Configuration modules and views:

- I have a module that add editable="bottom" in sale.line [1]
- I have two modules that inherit de sale_line_tree_view.
  - sale_discount: add new field in sale_line_tree_view [2]
  - sale_3_discounts: replace discount field in sale_discount module and add three fields in sale_tree_view [3]

I detected that when have two or more modules that inherit a view and is editable bootom, when click add new line, the editable fields are last module (in this example, fields from sale_3_discounts module) and other fields are not editables (can't click and edit product, quantity, etc)

- Detected SAO v5.2
- Working in GTK. It's ok.

[1] https://bitbucket.org/nantic/trytond-sale_edit_inline/src/default/view/sale_line_tree.xml
[2] https://bitbucket.org/trytonspain/trytond-sale_discount/src/default/view/sale_line_tree.xml
[3] https://bitbucket.org/nantic/trytond-sale_3_discounts/src/default/view/sale_line_tree.xml
History
Date User Action Args
2019-05-31 12:17:57cedsetstatus: chatting -> invalid
messages: + msg49927
2019-05-31 12:14:33restevesetstatus: invalid -> chatting
messages: + msg49926
2019-05-31 11:19:26cedsetstatus: need-eg -> invalid
messages: + msg49925
2019-05-28 10:10:18restevesetfiles: + issue8343.mp4
messages: + msg49882
2019-05-10 13:06:06cedsetstatus: chatting -> need-eg
priority: critical -> bug
messages: + msg49686
nosy: + ced
2019-05-10 12:45:51restevecreate

Showing 10 items. Show all history (warning: this could be VERY long)