Tryton - Issues

 

Issue8282

Title purchase UOM by supplier
Priority feature Status chatting
Superseder Nosy List ced, pokoli, risto3
Type feature request Components purchase
Assigned To Keywords
Reviews

Created on 2019-04-16.12:26:18 by risto3, last changed by ced.

Messages
msg49079 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-04-16.20:38:45
I guess a uom could be added on product supplier and used on_change on purchase line (and purchase request). But some care should be put in ensuring that nowhere else there is an implicit dependency on purchase_uom on product.
msg49078 (view) Author: [hidden] (risto3) Date: 2019-04-16.19:36:33
Well, no... I used (here) 'bar' to simply mean a predefined length of conduit or tube.  
Copper is frequently 5m, pvc 6m, galvanised circular conduit 3m and so on.  
They are all in the same category.

We use 5m (or 6m or 3m) to be the standard 'bar' lengths purchased.
The issue is when the suppliers for the same item use different purchase price units.  
Some have a unit price for the bar, some have a price per meter of the bar.
If issue8239 can handle these, then great.. I'll take a look soon.

I raised the discussion (I believe in the ML) way back for cases similar to 8239, but I didn't think 8239 specifically addressed the issue discussed here.

What would be real nice to have are product defined units, such as bar, box, sack, spool and so on where they could be set... perhaps these could be simply contextual synonyms... 
But I'm not asking for that here at the moment.

cheers
msg49075 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-04-16.18:21:41
For me, it is a duplicate of issue8239.
As far as I understand "bar" is not a unit of measure of category length (indeed it is probably a "Unit" instead of "bar"). So it is a secondary purchase unit.
msg49071 (view) Author: [hidden] (risto3) Date: 2019-04-16.13:22:27
okay, set to feature request... but it still doesn't work right yet:-)
msg49069 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2019-04-16.13:11:46
Not a bug but a feature request
msg49068 (view) Author: [hidden] (risto3) Date: 2019-04-16.12:26:17
Currently there is a default UOM by product
and a single purchase UOM for all suppliers.

Having a *default* purchase UOM is okay, but we need supplier specific
purchase UOM for overide as they may not use the same base.

For example: for bars 5m of copper Tubing
we have suppliers whose price is by the bar (5m) others by meter.

Naturally, for physical stock, we have the bars with the default UOM == 5m
For sale UOM (actually for project estimations) this is always by meter.

This is preventing us from merging these products with different suppliers.
History
Date User Action Args
2019-04-16 20:38:46cedsetnosy: + ced
messages: + msg49079
2019-04-16 19:45:51cedsetnosy: - ced
superseder: - Add secondary unit
2019-04-16 19:36:33risto3setstatus: closed -> chatting
messages: + msg49078
2019-04-16 18:21:41cedsetstatus: unread -> closed
superseder: + Add secondary unit
messages: + msg49075
nosy: + ced
2019-04-16 18:18:59cedsetcomponent: - product
2019-04-16 13:22:27risto3setstatus: chatting -> unread
messages: + msg49071
2019-04-16 13:11:46pokolisetpriority: bug -> feature
status: unread -> chatting
type: feature request
messages: + msg49069
nosy: + pokoli
2019-04-16 12:26:18risto3create

Showing 10 items. Show all history (warning: this could be VERY long)