Tryton - Issues

 

Issue8197

Title Error when Close Journal - Periods
Priority bug Status closed
Superseder Remove company record rules
View: 4080
Nosy List ced, iehoshia
Type crash Components account
Assigned To Keywords
Reviews

Created on 2019-03-14.00:00:49 by iehoshia, last changed by ced.

Messages
msg48997 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-04-13.23:43:26
Indeed there is no record rule for account.journal.period but we will not add them as the plan is to remove record rule see issue4080.
Users who want to work with multi-company has to setup themselves rules or help fixing issue4080.
msg47583 (view) Author: [hidden] (iehoshia) Date: 2019-03-14.00:00:48
Hi, 

I receive these message when I try to open Close Journal - Periods. 
You try to read records that don't exist anymore.
(Document type: account.period)

To reproduce it follow these steps in http://demo5.0.tryton.org: 

1. The default company is Michael Scott Paper Company
2. If you open "Close Journal - Periods" all its fine. 
3. Change user company to Dunder Mifflin inc company and change and login again. 
4. Open "Close Journal - Periods", you will receive the message. 

I think that is caused by the ir.rule of account.period and account.journal.period has no company field to filter each one. I will thenk how can I see correctly the "Close Journal - Periods".
History
Date User Action Args
2019-04-13 23:43:27cedsetstatus: unread -> closed
superseder: + Remove company record rules
messages: + msg48997
nosy: + ced
2019-03-14 00:00:49iehoshiacreate