Tryton - Issues

 

Issue8174

Title Tax code chart is empty
Priority bug Status closed
Superseder Nosy List ced, nicoe, pokoli, yangoon
Type behavior Components sao
Assigned To Keywords
Reviews

Created on 2019-03-05.15:41:27 by pokoli, last changed by pokoli.

Messages
msg49008 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2019-04-14.14:42:40
I've tested on the latest 5.0 branch and the issue is no more present.
msg48994 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-04-13.23:29:12
I tested the 5.0 demo version by creating a tax and tax code. And I can see the tax code with the right amount.
msg47437 (view) Author: [hidden] (nicoe) (Tryton committer) Date: 2019-03-06.10:01:51
I don't recall exactly how it stumbled on it but from the changeset description I guess it was something like:

Let's say you have the party form with some categories filled in.
If you delete the party the M2M will stay filled when all the other fields are emptied.

I think that in tryton there is not those tests also IIRC.
msg47436 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2019-03-06.09:55:36
@nicoe could you please give us some hint about what the change tried to fix?
msg47429 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2019-03-05.16:49:35
I can not reproduce the behaviour on trunk version but I can reproduce it on 5.0 branch. I've run a bisect and this behaviour is present since  changeset 6d1ec8938939
msg47426 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-03-05.15:50:46
It is probably linked to issue7839
msg47423 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2019-03-05.15:41:27
When opening the tax code chart (from Financial -> Charts - > Open Chart of Tax Codes) and selecting a period the values are always empty no mater if the period has tax values or not. 

It seems that the selected periods are not passed to the action as the Action title is neither completed with the selected records. 

The issue is reproducible on 5.0 series. This was working on sao-5.0.3 but not on sao-5.0.5
History
Date User Action Args
2019-04-14 14:42:40pokolisetstatus: need-eg -> closed
messages: + msg49008
2019-04-13 23:29:13cedsetstatus: chatting -> need-eg
messages: + msg48994
2019-03-08 00:57:42yangoonsetnosy: + yangoon
2019-03-06 10:01:52nicoesetmessages: + msg47437
2019-03-06 09:55:37pokolisetstatus: unread -> chatting
nosy: + nicoe
messages: + msg47436
2019-03-05 16:49:35pokolisetstatus: chatting -> unread
messages: + msg47429
2019-03-05 15:50:47cedsetstatus: unread -> chatting
nosy: + ced
messages: + msg47426
2019-03-05 15:42:20pokolisettitle: Tax code char is empty -> Tax code chart is empty
2019-03-05 15:41:28pokolicreate