Tryton - Issues

 

Issue8059

Title Make salabale and purchasable domain temporal
Priority feature Status resolved
Superseder Nosy List ced, reviewbot, roundup-bot
Type feature request Components purchase, sale
Assigned To ced Keywords easy, review
Reviews 54511002,56571002
View: 54511002, 56571002

Created on 2019-01-30.12:56:00 by ced, last changed by roundup-bot.

Messages
New changeset 8506c78847d9 by Cédric Krier in branch 'default':
Make salabale and purchasable domain temporal
https://hg.tryton.org/tryton-env/rev/8506c78847d9
New changeset 41ef7cfbcd02 by Cédric Krier in branch 'default':
Enforce salable product only for draft and quotation
https://hg.tryton.org/modules/sale/rev/41ef7cfbcd02
New changeset 64efb69c75c1 by Cédric Krier in branch 'default':
Enforce purchasable and supplier for draft and quotation
https://hg.tryton.org/modules/purchase/rev/64efb69c75c1
review56571002 updated at https://codereview.tryton.org/56571002/#ps1
review54511002 updated at https://codereview.tryton.org/54511002/#ps1
msg46632 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-01-30.12:56:00
If you remove salable or purchasable on a product that is used in a sale or purchase still processing, the processing will fail on the domain validation (even if the product is not changed because it depends on Function field which make it always validated).
I think those domain clause should only be enforced with the sale or purchase are still in draft or quotation.

Another option would be to use date range for salable and purchasable. But I think it makes the UX too complex for the benefit. And also it does not completely solve the problem is the dates are modified.

PS: I think it applies also to product_suppliers clause.
History
Date User Action Args
2019-02-13 10:41:10roundup-botsetmessages: + msg46982
2019-02-13 10:41:06roundup-botsetmessages: + msg46981
2019-02-13 10:40:57roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg46980
2019-01-31 19:05:35reviewbotsetmessages: + msg46670
2019-01-31 19:05:30reviewbotsetnosy: + reviewbot
messages: + msg46669
2019-01-31 18:50:58cedsetstatus: in-progress -> testing
reviews: 54511002,56571002
keyword: + review
2019-01-31 18:30:33cedsetstatus: unread -> in-progress
assignedto: ced
2019-01-30 12:56:00cedcreate