Tryton - Issues

 

Issue8056

Title General ledget initial debit and credit wrong values
Priority feature Status invalid
Superseder Nosy List ced, perilla, reviewbot, risto3
Type feature request Components account
Assigned To Keywords review
Reviews 53541002
View: 53541002

Created on 2019-01-28.19:07:42 by perilla, last changed by ced.

Files
File name Uploaded Type Edit Remove
DeepinScreenshot_Seleccionar área_20190128130249.png perilla, 2019-01-28.23:06:42 image/png
DeepinScreenshot_Seleccionar área_20190128130331.png perilla, 2019-01-28.19:08:05 image/png
Messages
msg48985 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-04-13.11:29:45
> I believe accountants consider, quite logically, that balance = debit - credit.

This is false. We talked to multiple accountant to design the GL and the balance/debit/credit behavior.
The debit/credit has no meaning over multiple years.

> The same for views, only displaying updated balance and not debit/credit is also incomplete.

No, the debit and credit are there to show how the balance evolved.
msg48984 (view) Author: [hidden] (risto3) Date: 2019-04-13.09:53:00
Perhaps should mention that I think that the right hand side is not quite correct in DeepinScreenshot_Seleccionar%20%C3%A1rea_20190128130249.png

What is more coherent is something like:

start debit  | start credit||   debit   | credit  || end debit  | end credit
=============+=============++===========+=========++============+===========
     0       | 11.307,98   || 11.307,98 |   0     ||   0        |   0

where [start|end] balance could be added to, or replace, the corresponding debit/credit tuple.
msg48983 (view) Author: [hidden] (risto3) Date: 2019-04-13.09:34:23
IMHO only computing the balance and not the debit/credit is incomplete.

I believe accountants consider, quite logically, that balance = debit - credit.

The same for views, only displaying updated balance and not debit/credit is also incomplete.
msg47070 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-02-15.22:50:44
Could we close this issue?
msg46581 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-01-30.09:40:50
For me, it is not a bug but a feature. Tryton took the choice to display only cumulated balance. Debit and credit are always for the current period.
msg46568 (view) Author: [hidden] (perilla) Date: 2019-01-28.19:17:00
I forget to say that it is tested with 5.0 version
New review53541002 at https://codereview.tryton.org/53541002/#ps1
msg46566 (view) Author: [hidden] (perilla) Date: 2019-01-28.19:09:40
Seems to be related with context used on get_account function,
inside General Ledger.

If I add cumulate=True inside context, computed values seem to be ok.
msg46565 (view) Author: [hidden] (perilla) Date: 2019-01-28.19:07:41
When I use general ledger report, Start Balance, and End Balance,
are computed with right values.

But If I show start_debit, start_cedit, and end_debit, and end_credit,
this values do not corresponding with start_balance and end_balance computed.
History
Date User Action Args
2019-04-13 11:29:49cedsetstatus: closed -> invalid
2019-04-13 11:29:45cedsetstatus: chatting -> closed
messages: + msg48985
2019-04-13 09:53:01risto3setmessages: + msg48984
2019-04-13 09:34:23risto3setnosy: + risto3
messages: + msg48983
2019-02-15 22:50:44cedsetpriority: bug -> feature
type: feature request
messages: + msg47070
2019-01-30 09:40:50cedsetnosy: + ced
messages: + msg46581
2019-01-28 23:06:46perillasetfiles: - DeepinScreenshot_Seleccionar área_20190128130331.png
2019-01-28 23:06:42perillasetfiles: + DeepinScreenshot_Seleccionar área_20190128130249.png
2019-01-28 19:17:00perillasetmessages: + msg46568
2019-01-28 19:16:11reviewbotsetnosy: + reviewbot
messages: + msg46567

Showing 10 items. Show all history (warning: this could be VERY long)