Issue 7961

Title
Add a way to bulk-add product (templates) to categories
Priority
feature
Status
resolved
Nosy list
ced, lordvan, pokoli, reviewbot, roundup-bot
Assigned to
pokoli
Keywords
review

Created on 2019-01-02.17:46:30 by lordvan, last changed 1 month ago by roundup-bot.

Messages

New changeset a09c69691f69 by Sergi Almacellas Abellana in branch 'default':
Allow multiple templates to be added/removed on a category
https://hg.tryton.org/tryton-env/rev/a09c69691f69
New changeset d6fb1bd8902b by Sergi Almacellas Abellana in branch 'default':
Allow multiple templates to be added/removed on a category
https://hg.tryton.org/modules/product/rev/d6fb1bd8902b
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2020-09-26.22:14:05
On 2020-09-26 19:30, Sergi Almacellas Abellana wrote:
> El 25/9/20 a les 22:40, Cédric Krier ha escrit:
> > Instead I think we should provide a link on the category form to open
> > another form with the Many2Many field to add products.
> 
> I like the idea of the link but for me the problem is that the current link widged does not allow to show the number of records of a Many2Many (only the ones for the action). So I'm wondering if it won't be better to add a counter (functional field) and a button to open the new view. 

By link I did not mean <link/> but a relate or a button (named
"Add Products").
I do not think it is needed to show any counter.
Author: [hidden] (pokoli) Tryton committer Tryton translator
Date: 2020-09-26.19:30:44
El 25/9/20 a les 22:40, Cédric Krier ha escrit:
> Instead I think we should provide a link on the category form to open
> another form with the Many2Many field to add products.

I like the idea of the link but for me the problem is that the current link widged does not allow to show the number of records of a Many2Many (only the ones for the action). So I'm wondering if it won't be better to add a counter (functional field) and a button to open the new view. 

What do you think?
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2020-09-25.22:40:03
On 2020-09-25 16:19, Sergi Almacellas Abellana wrote:
> This will load all the products of the category when opening the form. Is is ok or we need any extra optimization?

For me, it is an issue because it penalize users with large product
sets.
Instead I think we should provide a link on the category form to open
another form with the Many2Many field to add products.
Author: [hidden] (pokoli) Tryton committer Tryton translator
Date: 2020-09-25.16:19:00
Here is review308201003  which implements it by adding the many2many on the category form. 

This will load all the products of the category when opening the form. Is is ok or we need any extra optimization?
Author: [hidden] (lordvan)
Date: 2019-01-02.18:19:52
maybe put it in a wizard?
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2019-01-02.17:49:11
It means adding the reverse Many2Many on product.category but we should be careful to avoid unnecessary load because this list may contain a very large number of products.
Author: [hidden] (lordvan)
Date: 2019-01-02.17:46:29
Having to edit each product template to assign a category is not very efficient.

Would be best to be able to add products directly on the category UI with some way to bulk-select multiple at once
History
Date User Action Args
2020-11-23 18:05:28roundup-botsetmessages: + msg62137
2020-11-23 18:05:26roundup-botsetmessages: + msg62136
nosy: + roundup-bot
status: testing -> resolved
2020-11-16 10:32:41pokolisetstatus: in-progress -> testing
2020-11-12 10:27:26reviewbotsetmessages: + msg61855
2020-10-12 00:13:55reviewbotsetmessages: + msg60818
2020-10-09 23:23:38reviewbotsetmessages: + msg60755
2020-10-08 00:20:18reviewbotsetmessages: + msg60652
2020-09-26 22:14:05cedsetmessages: + msg60404
2020-09-26 19:30:44pokolisetstatus: testing -> in-progress
messages: + msg60401
2020-09-25 22:40:03cedsetmessages: + msg60393

Showing 10 items. Show all history (warning: this could be VERY long)