Tryton - Issues

 

Issue7817

Title One2Many ordering arrow wrongly stays after save
Priority bug Status resolved
Superseder Nosy List ced, reviewbot, roundup-bot, uha4
Type behavior Components sao, tryton
Assigned To ced Keywords review
Reviews 70481002
View: 70481002

Created on 2018-10-26.12:48:18 by uha4, last changed by roundup-bot.

Messages
New changeset 3fd04f47277a by Cédric Krier in branch 'default':
Keep column arrow up to date
https://hg.tryton.org/tryton-env/rev/3fd04f47277a
New changeset d4918be853dd by Cédric Krier in branch 'default':
Keep column arrow up to date
https://hg.tryton.org/tryton/rev/d4918be853dd
New changeset 06fc60dbe282 by Cédric Krier in branch 'default':
Keep column arrow up to date
https://hg.tryton.org/sao/rev/06fc60dbe282
review70481002 updated at https://codereview.tryton.org/70481002/#ps1
msg45448 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2018-12-21.19:52:34
Here is review70481002 which should keep arrows up to date.
msg44606 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2018-10-26.14:26:13
For me, there is a bug because the arrow stays and it is not the coded behavior because there is no code to reapply the previous order.
If you think the behavior could be improved then fill a new feature request for the new behavior.
msg44605 (view) Author: [hidden] (uha4) Date: 2018-10-26.14:07:25
I never used sao before, but its the same on http://demo5.0.tryton.org accessed with the browser.

If you say, it is normal behavior to reset the order at reload, perpaps i should change this from bug to feature or wish? My main point is, that it would be much more convienient if the order stays, especialy when just saving the record.
msg44604 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2018-10-26.13:23:00
Indeed the behavior on order is the expected one, on reload it should have the default order but the arrow on columns should be reset.
Could you check if the same happen on sao.
msg44602 (view) Author: [hidden] (uha4) Date: 2018-10-26.12:48:17
When you save or reload a record with one2many field, the sort order is lost. 

Reproduce:
Open a record with several lines in a one2many field, for example a shipment.
Sort the lines by clicking on the head of a column. than click save or reload. The lins are in their original order (by id i suppose) again.
The client remembers the prefered order, as the little arrow in the head of the column stays, but the lines ar not sorted any more, so to restore my order i have to click 3 times at the column again.

by the way: in the mail list view were all the records of a model are listed, this works fine.
History
Date User Action Args
2019-01-02 18:56:56roundup-botsetmessages: + msg45800
2019-01-02 18:56:53roundup-botsetmessages: + msg45799
2019-01-02 18:56:51roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg45798
2018-12-21 20:08:40reviewbotsetnosy: + reviewbot
messages: + msg45451
2018-12-21 19:52:34cedsetstatus: in-progress -> testing
reviews: 70481002
messages: + msg45448
keyword: + review
2018-12-21 19:49:47cedsetstatus: chatting -> in-progress
assignedto: ced
2018-12-21 19:10:02cedsetcomponent: + sao
2018-10-28 00:46:57cedsettitle: one2many widget: order lost when saving record -> One2Many ordering arrow wrongly stays after save
2018-10-26 14:26:13cedsetmessages: + msg44606
2018-10-26 14:07:26uha4setmessages: + msg44605

Showing 10 items. Show all history (warning: this could be VERY long)