Tryton - Issues

 

Issue7628

Title Filter error on Account General Ledger
Priority bug Status resolved
Superseder Nosy List ced, perilla, risto3, roundup-bot
Type behavior Components account
Assigned To ced Keywords review
Reviews 60421002
View: 60421002

Created on 2018-08-16.14:31:30 by perilla, last changed by roundup-bot.

Files
File name Uploaded Type Edit Remove
filter_by_dates.png perilla, 2018-08-16.14:36:43 image/png
filter_by_periods.png perilla, 2018-08-16.14:36:55 image/png
Messages
New changeset 1f96addd993e by Cédric Krier in branch '5.0':
Ensure GL per periods or dates are the same
https://hg.tryton.org/modules/account/rev/1f96addd993e

New changeset 8ab4f5aaca0f by Cédric Krier in branch '4.8':
Ensure GL per periods or dates are the same
https://hg.tryton.org/modules/account/rev/8ab4f5aaca0f

New changeset 7c818895032d by Cédric Krier in branch '4.6':
Ensure GL per periods or dates are the same
https://hg.tryton.org/modules/account/rev/7c818895032d
New changeset 998f55624214 by Cédric Krier in branch 'default':
Ensure GL per periods or dates are the same
https://hg.tryton.org/tryton-env/rev/998f55624214
New changeset ddae9f9c21f4 by Cédric Krier in branch 'default':
Ensure GL per periods or dates are the same
https://hg.tryton.org/modules/account/rev/ddae9f9c21f4
msg44750 (view) Author: [hidden] (risto3) Date: 2018-11-03.09:52:08
seems to work for me again with filter :
"Balance de départ": !0 or (Débit: !0 or Crédit: !0)"
msg44732 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2018-11-02.21:56:09
Here is review60421002
msg42928 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2018-08-16.15:59:12
I think it is because in get_period_ids period_ids is always filled with 0 for the start. So the period clause is added in query_get that match no period.
msg42926 (view) Author: [hidden] (perilla) Date: 2018-08-16.14:38:54
An better sample is get General Ledger with periods from: 2018-04 to 2018-12
And then get General Ledger with dates: from 2018-04-01 to 2018-12-31

I upload screenshots with results, on two cases.
msg42924 (view) Author: [hidden] (perilla) Date: 2018-08-16.14:31:29
When I use only from_date and to_date on general ledger,
result data never return start_balance.

To reproduce on http://demo4.8.tryton.org/
1.- Go to General Ledger Accounts
2.- Filter by Periods -> Start Period: 2018-06
3.- Click reload

Repeat with start date:
1.- Go to General Ledger Accounts
2.- Filter by Periods -> Start Date: 2018-06-01
3.- Click reload

IMHO results in two cases must be the same, but
only when filter by period, I get start_balance.
History
Date User Action Args
2018-11-25 22:00:26roundup-botsetmessages: + msg45013
2018-11-18 12:06:08roundup-botsetmessages: + msg44907
2018-11-18 12:06:00roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg44906
2018-11-03 09:52:09risto3setnosy: + risto3
messages: + msg44750
2018-11-02 21:56:10cedsetstatus: chatting -> testing
keyword: + review
messages: + msg44732
reviews: 60421002
assignedto: ced
type: behavior
2018-10-25 00:03:55cedlinkissue7772 superseder
2018-08-16 15:59:12cedsetnosy: + ced
messages: + msg42928
2018-08-16 14:38:54perillasetstatus: unread -> chatting
messages: + msg42926
2018-08-16 14:36:55perillasetfiles: + filter_by_periods.png
2018-08-16 14:36:43perillasetfiles: + filter_by_dates.png

Showing 10 items. Show all history (warning: this could be VERY long)