Tryton - Issues

 

Issue7603

Title Domain inversion does not work on sao when using a domain with multiple boolean conditions
Priority bug Status resolved
Superseder Nosy List ced, pablopadulles, pokoli, reviewbot, roundup-bot
Type behavior Components sao
Assigned To ced Keywords review
Reviews 56331002
View: 56331002

Created on 2018-08-02.20:50:08 by pablopadulles, last changed by roundup-bot.

Messages
New changeset ccb7109abf12 by Cédric Krier in branch '4.8':
Fix domain inversion evaluation of constrained field
https://hg.tryton.org/sao/rev/ccb7109abf12

New changeset d04a3ce20123 by Cédric Krier in branch '4.6':
Fix domain inversion evaluation of constrained field
https://hg.tryton.org/sao/rev/d04a3ce20123

New changeset 4bbcfd1a892c by Cédric Krier in branch '4.4':
Fix domain inversion evaluation of constrained field
https://hg.tryton.org/sao/rev/4bbcfd1a892c

New changeset f97a9d4be7b4 by Cédric Krier in branch '4.2':
Fix domain inversion evaluation of constrained field
https://hg.tryton.org/sao/rev/f97a9d4be7b4

New changeset c0367252b725 by Cédric Krier in branch '4.0':
Fix domain inversion evaluation of constrained field
https://hg.tryton.org/sao/rev/c0367252b725
New changeset e30446ac03ca by Cédric Krier in branch 'default':
Fix domain inversion evaluation of constrained field
https://hg.tryton.org/tryton-env/rev/e30446ac03ca
New changeset 532976d3ab2d by Cédric Krier in branch 'default':
Fix domain inversion evaluation of constrained field
https://hg.tryton.org/sao/rev/532976d3ab2d
review56331002 updated at https://codereview.tryton.org/56331002/#ps1
msg42853 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2018-08-10.00:12:01
Indeed it is the issue4073 which was not implemented in sao.
Here is review56331002
msg42796 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2018-08-08.11:26:28
So after viweing the videos I will resume it as Domain inversion does not work on sao when using a domain which includes a multiple boolean condition.
msg42627 (view) Author: [hidden] (pablopadulles) Date: 2018-08-03.14:46:48
In Sao -> https://youtu.be/PfRTykYBdZw

In tryton -> https://youtu.be/jW1Mj0Tgihc

The behavior is different with the domain
msg42626 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2018-08-03.13:26:26
I still do not understand. Please explain what is not working.
What is the expected behavior, what is the current behavior etc.
msg42625 (view) Author: [hidden] (pablopadulles) Date: 2018-08-03.13:19:14
a tree view work , the problem is when creating a new record with a m2o, and this m2o have domain BOOLEAN.
msg42619 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2018-08-03.00:23:14
I still do not understand. What is not working? What do you mean in a tree view?
msg42617 (view) Author: [hidden] (pablopadulles) Date: 2018-08-02.21:34:56
ok, i will do what I can....


class Model1(ModelSQL, ModelView):
    'Model1'
    __name__ = 'model.model'

    name = fields.Char('Char')
    bool1 = fields.Boolean(
        'bool1')
    bool2 = fields.Boolean(
        'bool2')


class Model2(ModelSQL, ModelView):
    'Model2'
    __name__ = 'model.model2'

    m2o = fields.Many2One('model.model',
            'Problema',
            domain=[
                ('bool1', '=', True),
                ('bool2', '=', True)
            ],
        )

This code, dont work when put NEW RECORD in M2O... in tree view work.
msg42616 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2018-08-02.21:18:37
I do not understand.
msg42613 (view) Author: [hidden] (pablopadulles) Date: 2018-08-02.20:50:08
In sao client in file M2O, domain dont work.

campo1 = fields.Many2One('model.model',
            'Problema',
            domain=[
                ('is_bool1', '=', True),
                ('is_bool2', '=', True),
            ]
        )

when is 1 domain work. 
In tryton work well.

In 4.6 and 4.8
History
Date User Action Args
2018-08-26 21:14:10roundup-botsetmessages: + msg43082
2018-08-18 22:51:10roundup-botsetmessages: + msg42944
2018-08-18 22:51:07roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg42943
2018-08-10 00:33:40reviewbotsetnosy: + reviewbot
messages: + msg42854
2018-08-10 00:12:01cedsetstatus: chatting -> testing
keyword: + review
messages: + msg42853
reviews: 56331002
assignedto: ced
type: behavior
2018-08-08 11:26:29pokolisetstatus: need-eg -> chatting
nosy: + pokoli
messages: + msg42796
title: Domain M2O whith Boolean file -> Domain inversion does not work on sao when using a domain with multiple boolean conditions
2018-08-03 14:46:48pablopadullessetmessages: + msg42627
2018-08-03 13:26:26cedsetmessages: + msg42626
2018-08-03 13:19:14pablopadullessetmessages: + msg42625
2018-08-03 00:23:14cedsetmessages: + msg42619

Showing 10 items. Show all history (warning: this could be VERY long)