Tryton - Issues

 

Issue7098

Title Unable to end subscription line without start date
Priority bug Status resolved
Superseder Nosy List pokoli, reviewbot, roundup-bot
Type behavior Components sale_subscription
Assigned To pokoli Keywords review
Reviews 44601002
View: 44601002

Created on 2018-01-30.16:19:37 by pokoli, last changed by roundup-bot.

Messages
New changeset 4c78f035036a by Sergi Almacellas Abellana in branch 'default':
Allow to finish subscriptions lines without start date
http://hg.tryton.org/modules/sale_subscription/rev/4c78f035036a
msg38460 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2018-02-19.11:50:43
Fixed in changeset 4c78f035036a
review44601002 updated at https://codereview.tryton.org/44601002/#ps1
msg38119 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2018-01-30.16:19:36
Steps to reproduce:

https://groups.google.com/d/msg/tryton/ssy_0TPapNU/sPz8pTE5BAAJ

The problem is that the end_date domain always ensures that the end_date is greater than the start_date, but when the start_date is not set this domain will fail.
History
Date User Action Args
2018-02-19 12:15:05roundup-botsetnosy: + roundup-bot
messages: + msg38463
2018-02-19 11:50:44pokolisetstatus: testing -> resolved
messages: + msg38460
2018-01-30 16:49:55reviewbotsetnosy: + reviewbot
messages: + msg38120
2018-01-30 16:22:54pokolisetstatus: in-progress -> testing
reviews: 44601002
keyword: + review
2018-01-30 16:19:37pokolicreate

Showing 10 items. Show all history (warning: this could be VERY long)