Tryton - Issues

 

Issue7059

Title IconFactory deprecated
Priority feature Status resolved
Superseder Nosy List ced, reviewbot, roundup-bot
Type behavior Components tryton
Assigned To ced Keywords review
Reviews 60291002
View: 60291002

Created on 2018-01-15.19:04:44 by ced, last changed by roundup-bot.

Messages
New changeset 3feeceb952bc by C├ędric Krier in branch 'default':
Use material design icons
https://hg.tryton.org/tryton/rev/3feeceb952bc
review60291002 updated at https://codereview.tryton.org/60291002/#ps60001
review60291002 updated at https://codereview.tryton.org/60291002/#ps50001
review60291002 updated at https://codereview.tryton.org/60291002/#ps40001
review60291002 updated at https://codereview.tryton.org/60291002/#ps30001
review60291002 updated at https://codereview.tryton.org/60291002/#ps20001
New review60291002 at https://codereview.tryton.org/60291002/#ps1
msg42534 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2018-07-28.23:44:37
Here is review60291002 which implement an alternative to the gtk.IconFactory.
The issue is that we rely on some icon inherited from the Gtk Theme. This should be fixed with the switch to Material icon: https://discuss.tryton.org/t/new-theme-icon-for-tryton/507
msg37833 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2018-01-22.09:37:10
I could not find a way to get the size of the icons from GTK. It is a problem because this size may depend on the theme (or CSS customization).
So I think we must go with the cache directory per host/database.
msg37696 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2018-01-19.22:21:01
I think the best option will be to no more try to register icons as GTK icon but just use pixbuf of the image in the memory and replace 'from_icon_name' by 'from_pixbuf'. The only drawback will be that we have to hard-code the icon size instead of using the constant from GTK. But we could just on startup, create an image using standard icon and request its size as reference.
msg37621 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2018-01-15.19:04:43
The IconFactory has been deprecated in GTK3 in favor of IconTheme [1].
We could convert the code to use it without too much difficulty by the method 'gtk_icon_theme_add_builtin_icon' [2] is also deprecated. This method would be needed to add icons from the server.
I think it is not useful to change IconFactory if it is to use another deprecated feature.
Indeed it looks like Gtk team does not want to allow to register icons using only pixmaps but instead to use directory path with icon files. So maybe a solution would be to store in a cache directory per host/database the icons fetched from the server and to preprend this path to the search path.

[1] https://developer.gnome.org/gtk3/stable/GtkIconTheme.html
[2] https://developer.gnome.org/gtk3/stable/GtkIconTheme.html#gtk-icon-theme-add-builtin-icon
History
Date User Action Args
2018-08-19 20:06:33roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg42987
2018-08-19 14:39:05reviewbotsetmessages: + msg42950
2018-08-06 09:34:50reviewbotsetmessages: + msg42642
2018-08-03 01:34:32reviewbotsetmessages: + msg42622
2018-08-01 18:35:27reviewbotsetmessages: + msg42592
2018-07-31 02:38:27reviewbotsetmessages: + msg42554
2018-07-31 02:17:47cedlinkissue474 superseder
2018-07-31 02:13:32cedlinkissue4025 superseder
2018-07-29 00:12:17reviewbotsetnosy: + reviewbot
messages: + msg42535
2018-07-29 00:12:16reviewbotsetreviews: 60291002
keyword: + review

Showing 10 items. Show all history (warning: this could be VERY long)