Tryton - Issues

 

Issue6934

Title Issue on filtering search on es_xx
Priority bug Status resolved
Superseder Nosy List ced, csotelo, pokoli, reviewbot, roundup-bot
Type behavior Components trytond
Assigned To ced Keywords review
Reviews 39971002
View: 39971002

Created on 2017-11-13.14:53:27 by csotelo, last changed by roundup-bot.

Messages
New changeset bc6af20a1863 by Cédric Krier in branch '4.6':
Fix import of issue6934 backport
http://hg.tryton.org/trytond/rev/bc6af20a1863

New changeset 7c8a735180b9 by Cédric Krier in branch '4.4':
Fix import of issue6934 backport
http://hg.tryton.org/trytond/rev/7c8a735180b9

New changeset ff8cf599c78f by Cédric Krier in branch '4.2':
Fix import of issue6934 backport
http://hg.tryton.org/trytond/rev/ff8cf599c78f
New changeset 881ad200af26 by Cédric Krier in branch '4.6':
Allow to search and order translated fields using the derivative translations
http://hg.tryton.org/trytond/rev/881ad200af26

New changeset a7de704b19f2 by Cédric Krier in branch '4.4':
Allow to search and order translated fields using the derivative translations
http://hg.tryton.org/trytond/rev/a7de704b19f2

New changeset 84699a782320 by Cédric Krier in branch '4.2':
Allow to search and order translated fields using the derivative translations
http://hg.tryton.org/trytond/rev/84699a782320
New changeset 71f03e973642 by Cédric Krier in branch 'default':
Allow to search and order translated fields using the derivative translations
http://hg.tryton.org/trytond/rev/71f03e973642
review39971002 updated at https://codereview.tryton.org/39971002/#ps1
msg37220 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2017-12-10.16:06:18
I think the patch should be back-ported even if it changes the API of the method _get_translation_join. It is a private method and without this change it is not possible to really use the derivative feature of languages.
msg37219 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2017-12-10.16:04:57
Here is review39971002
msg36863 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2017-11-13.15:20:53
The issue is that rev 049635454a98 did not update the _get_translation_join [1]. It should create a join for all parent languages and take the one with value and having the longer language code.


[1] http://hg.tryton.org/trytond/file/default/trytond/model/fields/field.py#l367
msg36862 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2017-11-13.15:17:59
Since changeset 049635454a98 because the translatable fields query [1] does not take in account the parent languages. 

[1] http://hg.tryton.org/trytond/file/0c1fbcaaf301/trytond/model/fields/field.py#l367
msg36861 (view) Author: [hidden] (csotelo) Date: 2017-11-13.14:53:26
After updating from 3.8 to 4.2, and installing es_PE as language, filters stop working on values set from xml install like Currencies.

Example

Searching for USD on

- es => 'Dólar' => works
- es_PE => 'Dólar' => no results

Looks like an issue on parent translations
History
Date User Action Args
2017-12-27 02:14:53roundup-botsetmessages: + msg37469
2017-12-26 23:49:40roundup-botsetmessages: + msg37468
2017-12-18 17:45:43roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg37347
2017-12-10 16:13:25reviewbotsetnosy: + reviewbot
messages: + msg37221
2017-12-10 16:06:18cedsetmessages: + msg37220
2017-12-10 16:04:57cedsetstatus: in-progress -> testing
reviews: 39971002
messages: + msg37219
keyword: + review
2017-12-10 14:39:08cedsetstatus: chatting -> in-progress
assignedto: csotelo -> ced
2017-11-27 17:54:43csotelosetassignedto: csotelo
2017-11-13 15:20:58cedsetkeyword: - es
2017-11-13 15:20:53cedsetnosy: + ced
messages: + msg36863

Showing 10 items. Show all history (warning: this could be VERY long)