Tryton - Issues

 

Issue6687

Title Can change party field in sale with lines
Priority bug Status resolved
Superseder Nosy List ced, nelghani, pokoli, reviewbot, roundup-bot
Type behavior Components sao
Assigned To ced Keywords review
Reviews 43461002
View: 43461002

Created on 2017-07-31.13:04:24 by nelghani, last changed by roundup-bot.

Files
File name Uploaded Type Edit Remove
SaleScreen.bmp nelghani, 2017-07-31.13:04:23 image/bmp
ScreenshotSAO.bmp nelghani, 2017-07-31.13:20:58 image/bmp
Messages
New changeset 6a5ec7e30d04 by C├ędric Krier in branch 'default':
Wait to have read all the fields before set state and display
http://hg.tryton.org/sao/rev/6a5ec7e30d04
review43461002 updated at https://codereview.tryton.org/43461002/#ps1
msg35526 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2017-09-04.17:57:08
Here is review43461002 that should fix the problem. It is a concurrency issue in the display of the form where the state of a field is computed before the value of another field, on which it depends, is yet loaded.
msg34912 (view) Author: [hidden] (nelghani) Date: 2017-07-31.13:34:51
Logout and reconnect to the server from SAO and you'll see that the party field become editable.
msg34911 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2017-07-31.13:32:40
Indeed the party field is writable on the first display of the view.
I guess it is because the lines are not yet loaded and so the states evaluation does not return readonly.
msg34910 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2017-07-31.13:28:21
I can not reproduce on sao using the demo database. What I tested is the following: 

1. Create a new sale.
2. Fill the party field (its editable)
3. Createa a new sale line with a product, 1 quantity. 

After step 3 the party field its no more editable. 

WHich is the expected behaviour. 

I also deleted the line, and then the party field becomes as editable another time. 

Could you explain which steps are you doing?

P.S: Could you check the browser console if there is any error there?
msg34909 (view) Author: [hidden] (nelghani) Date: 2017-07-31.13:24:35
I did a complete test
I could only erase and select a new party, but when submiting changes the party remains the unchanged.
I undestand that tryton client behavior is normal, and SAO should not allow party erase and selection
msg34908 (view) Author: [hidden] (nelghani) Date: 2017-07-31.13:20:58
Yes Imade the test on the same sale with a product line
see attached SAO screenshot
msg34907 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2017-07-31.13:12:29
The sale party is readonly when there are lines. If you remove the lines, you should be able to change the party. 

Are you sure on sao you also had lines on the sale?
msg34906 (view) Author: [hidden] (nelghani) Date: 2017-07-31.13:04:23
When using tryton client, I can't change nor erase party field in sale view even if its status is Draft
The field on the screen is read only  (See attanched screenshot)
I made the same action from SAO, and a was able to change the party on the sale view.
Test donne with server: demo.tryton.org
History
Date User Action Args
2017-09-07 21:04:21roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg35585
2017-09-04 18:22:08reviewbotsetnosy: + reviewbot
messages: + msg35528
2017-09-04 17:57:08cedsetstatus: in-progress -> testing
reviews: 43461002
messages: + msg35526
keyword: + review
2017-09-04 17:53:06cedsetstatus: chatting -> in-progress
assignedto: ced
2017-07-31 13:34:51nelghanisetmessages: + msg34912
2017-07-31 13:32:41cedsetstatus: need-eg -> chatting
component: + sao, - tryton
messages: + msg34911
nosy: + ced
title: Can't change nor erase party field in sale view (tryton 4.4) -> Can change party field in sale with lines
2017-07-31 13:28:22pokolisetmessages: + msg34910
2017-07-31 13:24:36nelghanisetmessages: + msg34909
2017-07-31 13:20:58nelghanisetfiles: + ScreenshotSAO.bmp
messages: + msg34908
2017-07-31 13:12:29pokolisetstatus: unread -> need-eg
nosy: + pokoli
messages: + msg34907

Showing 10 items. Show all history (warning: this could be VERY long)