Tryton - Issues

 

Issue6601

Title Account type per balance sign
Priority feature Status resolved
Superseder Nosy List Timitos, ced, josesalvador, pokoli, reviewbot, risto3, roundup-bot
Type feature request Components account, account_es, account_fr
Assigned To ced Keywords review
Reviews 262771002
View: 262771002

Created on 2017-06-25.20:29:03 by ced, last changed by roundup-bot.

Messages
New changeset 201190532d6d by Cédric Krier in branch 'default':
Add optional debit type on account
https://hg.tryton.org/tryton-env/rev/201190532d6d
New changeset ac6c4cb97c62 by Cédric Krier in branch 'default':
Add optional debit type on account
https://hg.tryton.org/modules/account_fr/rev/ac6c4cb97c62
New changeset 0dd35ac42aaf by Cédric Krier in branch 'default':
Add optional debit type on account
https://hg.tryton.org/modules/account_es/rev/0dd35ac42aaf
New changeset c08395de57a4 by Cédric Krier in branch 'default':
Add optional debit type on account
https://hg.tryton.org/modules/account/rev/c08395de57a4
review262771002 updated at https://codereview.tryton.org/262771002/#ps269021006
review262771002 updated at https://codereview.tryton.org/262771002/#ps256561002
msg55004 (view) Author: [hidden] (josesalvador) Date: 2020-01-23.11:42:24
I finally checked pgc_xxx_normal of spanish chart of accounts too and I don't find out any differences with the @pokoli's adjustments.
review262771002 updated at https://codereview.tryton.org/262771002/#ps288941002
msg54979 (view) Author: [hidden] (josesalvador) Date: 2020-01-21.17:27:30
I've checked pgc_xxx_pyme and match your adjustments.

I'll review pgc_xxx_normal later.
msg54908 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2020-01-20.10:15:23
@josesalvador: 4 eyes see more than 2, so feel free to review the spanish chart and comment if something is wrong
msg54899 (view) Author: [hidden] (josesalvador) Date: 2020-01-17.20:58:20
@pokoli, in case you thought it would be convenient to do another review of Spanish chart of accounts to ensure we've caught all accounts implied in debit type please ping me, so I can help here.
msg54875 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2020-01-14.19:01:04
There is also pgc_554 account which behaves like pgc_551 and pgc_5525. Here is it's details:

* pgc_554_normal
   * type: es_balance_inversiones_empresas_del_grupo_corto_plazo (normal) 
   * debit_type: es_balance_otros_pasivos_financieros_corto_plazo (normal)
* pgc_554_pyme
   * type: es_balance_inversiones_finanzieras_corto_plazo (pyme)
   * debit_type: es_balance_otras_deudas_corto_plazo (pyme)
msg54872 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2020-01-14.18:21:38
Here are the required changes for account_es (i've used the xml ids): 

* pgc_551_normal:
   * type: es_balance_inversiones_empresas_del_grupo_corto_plazo (normal) 
   * debit_type: es_balance_otros_pasivos_financieros_largo_plazo (normal)
* pgc_551_pyme
   * type: es_balance_inversiones_finanzieras_corto_plazo (pyme)
   * debit_type: es_balance_otras_deudas_corto_plazo (pyme)
* pgc_5525_normal
   * type: es_balance_inversiones_empresas_del_grupo_corto_plazo (normal) 
   * debit_type: es_balance_otros_pasivos_financieros_largo_plazo (normal)
* pgc_5525_pyme
   * type: es_balance_inversiones_finanzieras_corto_plazo (pyme)
   * debit_type: es_balance_otras_deudas_corto_plazo (pyme)
* pgc_5523 and pgc_5524
   * type: es_balance_otros_activos_financieros_empresas_grupo (normal)
   * type: es_balance_inversiones_empresas_del_grupo_largo_plazo (pyme)
   * debit_type: es_balance_deudas_empresas_grupo_corto_plazo
review262771002 updated at https://codereview.tryton.org/262771002/#ps276651002
review262771002 updated at https://codereview.tryton.org/262771002/#ps284701002
msg54806 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2020-01-10.17:22:39
Here is review262771002
There are few drawbacks:

* When opening an account type to show the containing account, I always show the accounts linked by any of the type or debit type no matter of the balance sign. It will be very complex and expensive to put a domain there.

* When a Many2One to account has a domain on type, I let only the initial type. I think in usual case, the debit type will have the same properties.

I have updated the account_fr by removing the TODO. But I do not know how to update account_es. Also I do not know if account_de needs an update. account_be does not (Belgium is always simpler and better organized :-)).
msg54718 (view) Author: [hidden] (risto3) Date: 2020-01-01.11:19:38
42x means here in the subaccounts, notably 421, 425 and 427 (not to mention others).

That Tryton doesn't set party_required forces either that one closes the account in order to create subaccounts (which is rarely done these days, at least for those using more modern accounting packages and more than an single employee or two) or override the model in order to set party_required and get on with it. 

I don't believe this to be off topic as creditor/debitor status is on a party basis, by definition... in tryton, party_required simplifies the treatment of these cases.
msg53328 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-11-18.17:55:55
I do not know what you are talking about, but there is no party_required on account 42: http://hg.tryton.org/modules/account_fr/file/536db8d9843f/account_fr.xml#l4944
Any way, this is off-topic.
msg53327 (view) Author: [hidden] (risto3) Date: 2019-11-18.17:52:00
since 2012 these have been using parties, just like 42x
msg53326 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-11-18.17:48:19
Such case should not use party_required but a new account must be created for each party if it is the willing to keep track for each party.
msg53324 (view) Author: [hidden] (risto3) Date: 2019-11-18.17:35:10
In the French plan, although for many accounts with parties have a movement needed to treat correctly the balance, unfortunately there are others that are not(such as for class 45).
msg53312 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2019-11-18.13:48:24
Account type is used balance sheet and profit and Loss. Both report agregateall information about all parties into a single type. So it does not affect the party_required flag.
msg53235 (view) Author: [hidden] (risto3) Date: 2019-11-15.22:22:23
balance for an account with party required is on a party basis not on a global account basis... by definition... otherwise there would be no party.
msg53214 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2019-11-15.14:55:00
> how will this issue take into consideration accounts with party_required?

What do you mean? I do not see any change should be done on accounts with party required.
msg53213 (view) Author: [hidden] (risto3) Date: 2019-11-15.14:47:23
BTW, how will this issue take into consideration accounts with party_required?
msg53132 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2019-11-11.09:31:27
Once implemented the Spanish chart of accounts should be updated to use this feature. See: 

https://discuss.tryton.org/t/account-es-balance-sheet/1928
msg34298 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2017-06-27.14:43:03
This issue is about implementing (and/or improving) msg34227. This is not a place for general discussion.
msg34293 (view) Author: [hidden] (risto3) Date: 2017-06-27.14:11:48
? I made no compete proposal for reports, only to try to alleviate the misrepresentation of the account type (at least as noticed in the French plan) and a suggestion for a filter to simplify a reporting need.

The reports themselves will need to be revisited, naturally, and they *should* be conformant to national standards.

If for example a bank account is 'creditor' (or overdrawn) then the report should have it under liabilities as its current value implies a debt. Otherwise it is a liquid 'asset'. Similar for third-party or auxilliary (partner) accounts.

This doesn't appear to be the case for at least the French plan
and as such presents inexact reports.

I tried creating a new base with a company using simply the minimal account plan and I noticed similar difficulties as with the French plan, hence my suggestion/observation.

Noticing now in the account plan that 'kind' is already there (which is more or less a superset of what I suggested earlier). The difficulty seems to stem from the required secondary 'type' which simply cannot be static for all account types (or rather, 'kinds').

Trial balance and GL *are* static reports and naturally don't normally even refer to these 'types'. (pm: view accounts are still problematic)

From the initial issue problem statement, I believe I read that you maintain that this is an exceptionnal case in a some country (France). 

Can you cite perhaps at least one country where the issue is *not* exhibited? As is logical, it does seems rather pervasive from my limited research.
msg34268 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2017-06-27.11:46:54
If you do not make required to put all accounts in the report tree, you will miss some. So the current design ensure that every account is places somewhere in the report tree. Your proposal does not ensure that.
msg34267 (view) Author: [hidden] (risto3) Date: 2017-06-27.11:15:19
? best design ? missing accounts ? quésaco ?
msg34264 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2017-06-27.10:45:49
It is the best design to have reports with missing accounts.
msg34260 (view) Author: [hidden] (risto3) Date: 2017-06-27.10:22:41
I'm curious as to whether the 'type' should not simply limited to:
- Balance sheet accounts
- Profit and loss accounts
and perhaps
- Special Accounts

Individual accounting plans can then break these types down
into classes for their particular account heirarchy (whether
developed or simplified)

Perhaps it is best left to the various reports to be able to 
then select the accounts into the various sections and eventually 
detailed by specific account balance criteria such as:
 * debitor balance (only take if balance is debitor)
 * creditor balance ("                    " creditor)
 * both debitor or creditor (which is probably the general case)

there may be need for some reports to access as well:
* debit moves (only take the sum of the debit moves)
* credit moves ("                     " credit moves)

this is because the 'type' doesn't change, at least not without
perhaps somewhat radical consequences.
msg34227 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2017-06-25.20:29:03
Some country has a balance sheet for which the type of account change depending on the balance sign.
I think the best is to add a second type Many2One on account that will be used for negative balance. This new field can stay empty to have the same behavior than now.
History
Date User Action Args
2020-03-28 14:18:25roundup-botsetmessages: + msg56733
2020-03-28 14:18:19roundup-botsetmessages: + msg56732
2020-03-28 14:18:12roundup-botsetmessages: + msg56731
2020-03-28 14:18:07roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg56730
2020-03-07 00:30:26reviewbotsetmessages: + msg56143
2020-02-15 01:59:53reviewbotsetmessages: + msg55380
2020-01-23 11:42:25josesalvadorsetmessages: + msg55004
2020-01-22 21:58:05reviewbotsetmessages: + msg54996
2020-01-21 17:27:31josesalvadorsetmessages: + msg54979
2020-01-20 10:15:23pokolisetmessages: + msg54908

Showing 10 items. Show all history (warning: this could be VERY long)