Tryton - Issues

 

Issue4570

Title account_fr: Properly handle EU-sales and EU-purchases in the VAT report
Priority bug Status resolved
Superseder Nosy List ced, rhertzog, roundup-bot
Type behavior Components account_fr
Assigned To rhertzog Keywords review
Reviews 14011003,7931002,6061002,6071002,6071003,6081002,14011002,7941002
View: 14011003, 7931002, 6061002, 6071002, 6071003, 6081002, 14011002, 7941002

Created on 2015-02-16.20:43:29 by rhertzog, last changed by roundup-bot.

Messages
New changeset 1b5fa65cbe2a by Raphaël Hertzog in branch 'default':
Add a tax rule for purchase outside Europe
http://hg.tryton.org/modules/account_fr/rev/1b5fa65cbe2a
msg20256 (view) Author: [hidden] (rhertzog) (Tryton committer) Date: 2015-02-17.16:07:18
I moved review14011003 at the top of the patch set, it's more logical to start with the deletion of things that are wrong and that we don't want to support. I updated all other reviews accordingly and I also integrated the first comments of the reviewers.
msg20249 (view) Author: [hidden] (rhertzog) (Tryton committer) Date: 2015-02-17.09:56:16
BTW, the case you mention for this year (sales of services sold via internet) is for sales to individuals, sales to companies subject to VAT are still exempt of VAT under the rules of auto-liquidation.

And the last commit is precisely about dropping the tax rule that incorrectly tried to cover the sales to individuals. So in fact I agree with you that sales to individuals is too complicated and out of scope currently.
msg20248 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2015-02-17.09:35:27
I think the problem is not the tax definition but the rules definition.
The best will be to do the same as for account_be where we did not put any rules for purchase and only simple rule for sale like for services (but goods are way too complex).
Also I think it will be easier to review it as a all because what cares is the integrity of the data not the process you followed to get them.
msg20246 (view) Author: [hidden] (rhertzog) (Tryton committer) Date: 2015-02-17.08:57:20
I have spent days preparing this update (including reading lots of documentation about the requirements for the VAT report) and the perspective of having done this work for nothing does not please me. I am fully aware that the rules are more complicated than the standard cases that I have covered and that we used to pretend to cover.

However I don't agree that it's better to have nothing for EU purchases/sales. I do use everything that I have prepared here and it is thus useful. But I agree that we ought to provide some guidance about the limitations. Where is the user documentation associated to account_fr ? I can try to provide a patch to document what we have ready and what cases are not covered.
msg20244 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2015-02-16.23:23:21
I have some doubt about creating taxes for goods and services inside the Europe because the rules are quite complex and depend a lot of the business.
For example, this year for services sold via internet to customer, you have to use the tax rate of the customer.
So I think it is better to not have taxes than having almost good taxes.
But I think that splitting the taxes between services and goods is a good step.
msg20242 (view) Author: [hidden] (rhertzog) (Tryton committer) Date: 2015-02-16.20:43:27
The current handling of the EU-sales and EU-purchases is wrong and doesn't allow to fill all the data that the VAT report requires us to provide. We have to provide data for goods and service (both for sales and for purchases). Getting the situation straight thus requires to create separate taxes for goods and for services.

I have a branch fixing all this and I'm submitting it here in this ticket with multiple reviews. Here's the "git log" (from oldest commit to newest one) to explain the different steps:

http://codereview.tryton.org/7931002

    Differentiate VAT sales taxes between goods and services
    
    The current taxes are dedicated for the goods and we create
    new taxes dedicated to services.

http://codereview.tryton.org/6061002

    Differentiate VAT purchase taxes between goods and services
    
    The current purchase taxes are dedicated for the goods and we create
    new taxes dedicated to services.
    
    This split is not needed for national purchases but it's required
    so that we can properly map them to different taxes for purchases
    in Europe.

http://codereview.tryton.org/6071002

    Split the tax for sales without VAT within Europe in goods and services
    
    And also:
    * Fix the associated accounts and tax codes:
      - the invoice_account doesn't matter since the rate is 0, but we
        use the standard account for collected VAT (44571 TVA collectée)
      - the invoice_tax_code/credit_note_tax_code are set to None since
        there's no point to assign a zero value anywhere
      - the invoice_base_code varies between services (0033 Autres opérations
        non imposables) and goods (0034 Livraisons intracommunautaires)
      - the credit_note_base_code is set to 0039 (Régularisations sur
        opérations non-imposables)
    * Expand the tax rule for sales without VAT in Europe to map the new
      taxes. Each tax for goods maps to tva_vente_intracommunautaire_0,
      each tax for services maps to tva_vente_intracommunautaire_services_0.

http://codereview.tryton.org/6071003

    Define and fix taxes for purchase of goods in Europe
    
    * Dedicate the pre-existing taxes to purchase of goods.
    * Create the missing taxes for the "Taux intermédiaire".
    * Drop the credit_note_base_code and credit_note_tax_code as
      credit note on EU purchases do not change the amount of VAT
      to pay (since they are auto-liquidated). However we still
      cancel the amount recorded in 0032/0044.
    * Fix all the invoice_base_code and invoice_tax_code to match
      the legal requirements and the logic explained in the
      newly added comment.

http://codereview.tryton.org/6081002

    Create taxes for purchase of services in Europe
    
    Basically we copy the taxes for purchases of goods, changing the tax codes
    as appropriate.
    
    The base amount is now recorded in 0044 instead of 0031, and the tax
    amount doesn't need to be counted separately (there's no
    service-equivalent of the 0035 field). This enables us to do everything
    with 2 sub-taxes only.

http://codereview.tryton.org/14011002

    Add a tax rule for purchase in Europe

http://codereview.tryton.org/7941002

    Add a tax rule for purchase outside Europe
    
    The tax rule cancels all the purchase VAT: there is no need to account or
    declare this.

http://codereview.tryton.org/14011003

    Remove tax rule "Ventes intracommunautaires" and associated taxes
    
    There is no need for these taxes: in case of sale of goods in Europe
    where there is no VAT exemption (i.e. sales to individuals), we have
    to record and declare this sale and the VAT as if the sale was made in
    France.
History
Date User Action Args
2015-03-06 15:46:40roundup-botsetstatus: chatting -> resolved
nosy: + roundup-bot
messages: + msg20501
2015-02-17 16:07:19rhertzogsetreviews: 7931002,6061002,6071002,6071003,6081002,14011002,7941002,14011003 -> 14011003,7931002,6061002,6071002,6071003,6081002,14011002,7941002
messages: + msg20256
2015-02-17 09:56:16rhertzogsetmessages: + msg20249
2015-02-17 09:35:28cedsetmessages: + msg20248
2015-02-17 08:57:21rhertzogsetmessages: + msg20246
2015-02-16 23:23:22cedsetstatus: unread -> chatting
nosy: + ced
messages: + msg20244
2015-02-16 20:43:29rhertzogcreate

Showing 10 items. Show all history (warning: this could be VERY long)