Issue 4492

Title
Error in Calendar view in 3.2 for February 2015
Priority
bug
Status
closed
Nosy list
avallop, ced, mar, smn
Assigned to
Keywords

Created on 2015-01-15.12:53:17 by smn, last changed 69 months ago by ced.

Messages

Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2015-02-05.17:27:59
Definitely if it is a bug in GooCalendar that happens only on February month started on Sunday (so ~once every 7-14 years).
I close this one as the tracking of the issue will be done on goocalendar tracker.
Author: [hidden] (mar)
Date: 2015-02-05.15:32:35
I think related is http://code.google.com/p/goocalendar/issues/detail?id=4
Author: [hidden] (avallop)
Date: 2015-02-02.21:01:46
Hello again, I have just upgrade to Gnu Health 2.8 and Calendar has the same problem using Tryton client for Windows in version 3.4.1.
Author: [hidden] (avallop)
Date: 2015-02-02.19:08:58
Hello, i have the same issue with Gnu Health 2.6.4 and Tryton client for Windows in versions 3.2.2 and 3.2.4.

Here is my client trace: 

File "tryton\gui\window\view_form\view\calendar_gtk\parser.pyc", line 71, in parse

 

  File "tryton\gui\window\view_form\view\calendar_gtk\calendar_.pyc", line 22, in __init__

 

  File "tryton\gui\window\view_form\view\calendar_gtk\calendar_.pyc", line 42, in get_displayed_period
Author: [hidden] (smn)
Date: 2015-01-31.14:05:01
Here it is, the client trace:

File "<HOME_PATH>/tryton/tryton/gui/window/view_form/view/calendar_gtk/parser.py", line 22, in on_page_changed
    if goocalendar.update_domain():

  File "<HOME_PATH>/tryton/tryton/gui/window/view_form/view/calendar_gtk/calendar_.py", line 48, in update_domain
    displayed_period = self.get_displayed_period()

  File "<HOME_PATH>/tryton/tryton/gui/window/view_form/view/calendar_gtk/calendar_.py", line 42, in get_displayed_period
    last_date = weeks[5][6]

Please note original working path of trace has been replaced for <HOME_PATH>.

Thanks in advance.
Author: [hidden] (smn)
Date: 2015-01-29.17:25:45
It's the trace given by tryton OS X client downloaded from official site. I haven't got the environment prepared to debug client.
Anyway I'll try to debug it in linux and paste the trace.
Author: [hidden] (mar)
Date: 2015-01-29.14:36:28
I think the trace you've pasted is missing important information
Author: [hidden] (smn)
Date: 2015-01-15.12:53:16
It seems to be a bug with this month in Calendar view.
I'm working with version 3.2.5 in OSX Yosemite (but I've tested that it crashes in Fedora 19 as well).
Can be reproduced in any calendar view, for instance in calendar of production module. Do Double-click in menu of calendar's production view and change month to February. The error appears:

Error: list index out of range.
File "tryton/gui/window/view_form/view/calendar_gtk/parser.pyc", line 22, in on_page_changed

File "tryton/gui/window/view_form/view/calendar_gtk/calendar_.pyc", line 48, in update_domain

File "tryton/gui/window/view_form/view/calendar_gtk/calendar_.pyc", line 42, in get_displayed_period
History
Date User Action Args
2015-02-05 17:27:59cedsetstatus: chatting -> closed
nosy: + ced
messages: + msg20054
2015-02-05 15:32:37marsetnosy: + mar
messages: + msg20052
2015-02-02 21:01:47avallopsetmessages: + msg19987
2015-02-02 19:08:59avallopsetnosy: + avallop
messages: + msg19986
2015-01-31 14:05:02smnsetmessages: + msg19961
2015-01-29 17:25:46smnsetmessages: + msg19947
2015-01-29 14:36:48marsetnosy: - mar
2015-01-29 14:36:29marsetstatus: unread -> chatting
nosy: + mar
messages: + msg19946
2015-01-15 12:53:17smncreate

Showing 10 items. Show all history (warning: this could be VERY long)