Tryton - Issues

 

Issue4464

Title CSV export unusable on tree views
Priority feature Status closed
Superseder Nosy List albertca, rhertzog
Type behavior Components tryton
Assigned To Keywords
Reviews

Created on 2015-01-08.16:00:02 by rhertzog, last changed by albertca.

Messages
msg24354 (view) Author: [hidden] (albertca) (Tryton committer) Date: 2016-02-25.21:34:29
This has been solved in v3.8.
msg19514 (view) Author: [hidden] (rhertzog) (Tryton committer) Date: 2015-01-08.23:39:25
You mean that this ticket is a "feature request", OK.

But (to me) the missing feature looks like a bug in the implementation of the CSV export feature :-)
msg19497 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2015-01-08.16:12:27
Not a bug but a feature.
msg19496 (view) Author: [hidden] (rhertzog) (Tryton committer) Date: 2015-01-08.16:00:00
CSV export is an important feature to analyze data in other tools (be it text-based tools like diff, or a simple spreadsheet). Yet CSV export is not working satisfactorily on all hierarchical views (which is most views for accounts, taxes, etc.) because it will only export top-level entries and there is no way to export all childrens.

In some case this can be worked around by using the sub-view that offers a flat view of the same objects, but there are two problems here: not all objects have a flat view (for instance account templates do not have such a view) and some of those flat views voluntarily filter out childrens (that seems to be the case for taxes).

Please consider modifying the logic to export all children by default.
History
Date User Action Args
2016-02-25 21:34:30albertcasetstatus: chatting -> closed
nosy: + albertca
messages: + msg24354
2015-01-08 23:39:25rhertzogsetmessages: + msg19514
2015-01-08 16:12:36cedsetnosy: - ced
2015-01-08 16:12:27cedsetpriority: bug -> feature
status: unread -> chatting
messages: + msg19497
nosy: + ced
2015-01-08 16:00:02rhertzogcreate

Showing 10 items. Show all history (warning: this could be VERY long)