Issue 4102

Title
tryton-icon.png no such file or directory
Priority
bug
Status
resolved
Nosy list
ceciliasp, ced, german, notzippy, roundup-bot
Assigned to
notzippy
Keywords
review

Created on 2014-08-04.01:43:51 by ceciliasp, last changed 67 months ago by ced.

Messages

Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2015-03-31.22:06:16
No, it is a new feature which is against maintenance policy.
Author: [hidden] (german)
Date: 2015-03-31.20:36:49
Can we backport the change to the 3.2 branch? I've tried locally and it works.

Regards
New changeset 4e8f9a35cc52 by C?dric Krier in branch 'default':
Added search for pixmaps in site.USER_BASE
http://hg.tryton.org/tryton/rev/4e8f9a35cc52
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2014-10-06.22:19:48
There is no where mention of pushing: https://code.google.com/p/tryton/wiki/HowtoContribute#Pushing_your_commit
Author: [hidden] (notzippy)
Date: 2014-10-06.22:10:55
Read it, I completed everything down to this section

Pushing your commit

With SSH access
Clone the repository or update (hg pull ; hg update) an existing copy
hg clone ssh://USERNAME@hg.tryton.org//home/hg/trytond
Replace USERNAME, use the right repository (replace trytond by tryton or modules/NAME as needed)
Add your commit
Use hg outgoing command and check the changes
Push: hg push
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2014-10-06.22:09:23
Of course, you can not push, see https://code.google.com/p/tryton/wiki/HowtoContribute
Author: [hidden] (notzippy)
Date: 2014-10-06.21:47:59
Cannot push 

pushing to http://hg.tryton.org/tryton
searching for changes
new remote heads on branch 'default'
new remote head e90e527cccf5
abort: push creates new remote head e90e527cccf5!
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2014-09-25.08:24:08
Where is it?
Author: [hidden] (notzippy)
Date: 2014-09-25.05:08:05
Sorry for delay, patch committed. changeset:   4105:e90e527cccf5
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2014-09-24.08:47:40
Could you provide the patch as explained in https://code.google.com/p/tryton/wiki/HowtoContribute
Author: [hidden] (notzippy)
Date: 2014-09-22.21:31:56
Did not realize it was not neccessary
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2014-09-22.21:30:40
Why repeating the review url?
Author: [hidden] (notzippy)
Date: 2014-09-16.23:42:19
http://codereview.tryton.org/12541002/
Author: [hidden] (notzippy)
Date: 2014-09-16.23:39:13
Working on fix
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2014-09-16.23:14:02
Could you propose a patch following: https://code.google.com/p/tryton/wiki/HowtoContribute
Author: [hidden] (notzippy)
Date: 2014-09-16.22:30:49
Yes that works as well, less is more !

    PIXMAPS_DIR = os.path.join(site.USER_BASE, "share", "pixmaps", "tryton")
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2014-09-16.21:09:41
I think it will be better to use site.USER_BASE
https://docs.python.org/2/library/site.html#site.USER_BASE
Author: [hidden] (notzippy)
Date: 2014-09-16.18:12:12
I would like to reopen this, this is apparent when you install the tryton component using the --user option like
pip --user tryton
The fix is adding 4 lines of code to config.py to also look in the <executable folder>/../share/pixmap/tryton folder.

if not os.path.isdir(PIXMAPS_DIR):
    PIXMAPS_DIR = os.path.join(sys.prefix, 'share', 'pixmaps', 'tryton')
+if not os.path.isdir(PIXMAPS_DIR):
+    path_to_tryton = os.path.realpath(sys.argv[0])
+    PIXMAPS_DIR = os.path.join(os.path.dirname(path_to_tryton), os.pardir, "share", "pixmaps", "tryton")
+    PIXMAPS_DIR = os.path.normpath(PIXMAPS_DIR)
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2014-08-04.18:50:54
As you don't give the exact command run, I can not help more than guessing.
"pip install tryton" must install tryton in your sys.prefix path (generally: /usr or /usr/local). Here I see that there are tryton stuff in you ~/.local directory so it is junk as it conflict with the initial installation.
If you can not manage installation with pip (which is far from being a easy tool), the best is to stick with the package manager of your distribution.
See http://www.tryton.org/download.html#packages

I close the issue as far as I don't see any real issue for tryton here.
Re-open it if there are still an issue once the junk in ~/.local is cleaned.
Author: [hidden] (ceciliasp)
Date: 2014-08-04.18:18:28
I have followed the instructions detailed in http://en.wikibooks.org/wiki/GNU_Health/Installation.
I am sorry if I am not provinding with the exact information but I am new to tryton and GnuHealth.
What do you mean by "junk in your /.local?
How can I fix this?
I tried also with a virtual machine in Ubuntu 12.04 and get the same error.
Regards
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2014-08-04.18:15:58
I don't know what you mean by "official documentation".
But if you did a simple "pip install tryton" then you have junks in your ~/.local
Author: [hidden] (ceciliasp)
Date: 2014-08-04.17:48:12
Both client and server running on Linux (Solydx Debian).
Tryton Server and Client version 3.2.2
Installed through pip installed and followed official documentation.
Txs
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2014-08-04.09:50:10
Again, how was it installed (command, environment etc.).
Which version? Which OS?
Author: [hidden] (ceciliasp)
Date: 2014-08-04.01:43:50
I had a similar problem with icons folder and I was advice to upgrade to latest version of Tryton.
I've upgraded to both Server and Client to the latest version and now I get this error
"Traceback (most recent call last):
  File "/usr/bin/tryton", line 45, in <module>
    import tryton
  File "/home/solydx/.local/lib/python2.7/site-packages/tryton/__init__.py", line 3, in <module>
    import client
  File "/home/solydx/.local/lib/python2.7/site-packages/tryton/client.py", line 24, in <module>
    import tryton.common as common
  File "/home/solydx/.local/lib/python2.7/site-packages/tryton/common/__init__.py", line 3, in <module>
    from common import *
  File "/home/solydx/.local/lib/python2.7/site-packages/tryton/common/common.py", line 14, in <module>
    from tryton.config import CONFIG
  File "/home/solydx/.local/lib/python2.7/site-packages/tryton/config.py", line 193, in <module>
    os.path.join(PIXMAPS_DIR, 'tryton-icon.png').encode('utf-8'))
glib.GError: Failed to open file '/usr/bin/share/pixmaps/tryton/tryton-icon.png': No such file or directory"
History
Date User Action Args
2015-04-16 17:09:46cedlinkissue4705 superseder
2015-03-31 22:06:17cedsetstatus: chatting -> resolved
messages: + msg20995
2015-03-31 20:36:50germansetstatus: resolved -> chatting
nosy: + german
messages: + msg20994
2014-10-10 10:14:27roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg18500
2014-10-06 22:19:49cedsetmessages: + msg18460
2014-10-06 22:10:55notzippysetmessages: + msg18456
2014-10-06 22:09:23cedsetmessages: + msg18455
2014-10-06 21:48:00notzippysetmessages: + msg18454
2014-09-25 08:24:09cedsetmessages: + msg18338
2014-09-25 05:08:06notzippysetmessages: + msg18337

Showing 10 items. Show all history (warning: this could be VERY long)