Tryton - Issues

 

Issue3589

Title neso 3.0: After each launch, there is always 'Create Database' button
Priority urgent Status resolved
Superseder Nosy List ced, dominik, oscar, pokoli, roundup-bot, tkhyn, vezjakv
Type behavior Components trytond
Assigned To ced Keywords review
Reviews 3991002
View: 3991002

Created on 2014-01-14.09:38:19 by vezjakv, last changed by ced.

Messages
New changeset b544598a1eaa by C?dric Krier in branch '3.0':
Use raw SQL string to test database
http://hg.tryton.org/trytond/rev/b544598a1eaa
msg15824 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2014-03-02.22:33:14
Proposed patch solved the problem for me.
msg15823 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2014-03-02.22:15:16
Indeed it was fixed in trunk with changeset 610cf1f6c946 but we can not backport
this patch because of API changes.
So here is a patch that re-use the old raw SQL string for 3.0
msg15822 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2014-03-02.21:21:31
I executed more code and it fails in the test query, concrectly in [1]. I get
the following traceback:

Traceback (most recent call last):
  File "C:\Program Files\neso-3.0.0\neso.py", line 150, in <module>
    cursor2.execute(sql, params)
  File "trytond\trytond\backend\sqlite\database.pyc", line 342, in execute
OperationalError: near "%": syntax error

Which is quite strange for me. 

I also printed the generated query and params, which lead to: 

('SELECT "a"."name" FROM "sqlite_master" AS "a" WHERE (("a"."type" = %s) AND
("a"."name" IN (%s, %s, %s, %s, %s, %s, %s, %s, %s, %s)))', ('table',
'ir_model', 'ir_model_field', 'ir_ui_view', 'ir_ui_menu', 'res_user',
'res_group', 'ir_module_module', 'ir_module_module_dependency',
'ir_translation', 'ir_lang'))

Let me know if more inputs are needed. 

[1]
http://hg.tryton.org/trytond/file/cb04e75618bf/trytond/backend/sqlite/database.py#l382
msg15821 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2014-03-02.20:05:20
Just to confirm this issue only affects windows, as I can reproduce it on a
Windows VM machine, but not on my linux box. 

Just installed a python shell on the Windows VM machine and I tried list dirs of
the folder and they are correctly listed, so the problem may be opening the
cursor to the database. 

I also installed sqlite-cli on the windows machine and I can access the database
without problems. 

Any tips about how to run neso from sources on windows, or how to create
neso.exe (as Oscar already pointed) will be great to solve the issue.
msg15592 (view) Author: [hidden] (tkhyn) Date: 2014-02-12.16:13:39
Same issue here, reproduced on Win 7 Pro 32 as well as on Windows XP Pro 32.
msg15377 (view) Author: [hidden] (dominik) Date: 2014-01-29.11:15:14
I am testing on Windows 8 Enterprise 64-Bit.
msg15363 (view) Author: [hidden] (oscar) (Tryton translator) Date: 2014-01-28.00:18:21
To exist any way for to create neso.exe, from neso.py for test/hack in my pc,
using print another changes maybe I help, but I don't know how create neso.exe
correctly.
msg15362 (view) Author: [hidden] (oscar) (Tryton translator) Date: 2014-01-28.00:14:36
I tested on  Windows 7 ultimate, 32 bits, Virtualbox
msg15361 (view) Author: [hidden] (vezjakv) (Tryton translator) Date: 2014-01-27.20:14:56
I've tested on Windows 7 Enterprise SP1, build 7601, x64.
msg15360 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2014-01-27.20:06:51
It will be strange to be allowed to create a file but not read it back.

Any way, everyone having this issue, could you provide the version of each OS
where this happens?
msg15359 (view) Author: [hidden] (oscar) (Tryton translator) Date: 2014-01-27.19:57:40
I have de same problem in windows7, maybe it is a problem of permissions on file
c:\users\<username>\.neso\3.0\demo.sqlite.
msg15286 (view) Author: [hidden] (vezjakv) (Tryton translator) Date: 2014-01-23.13:42:56
I can also produce the scenario as dominik described.
But after closing neso client, the symptoms are back
again.
msg15285 (view) Author: [hidden] (dominik) Date: 2014-01-23.13:16:48
Having the same problem here.
But if I create a new databasem,connect to the new database and then select in 
the menu to connect to another databse, then the neso client then finds the old 
database.
msg15179 (view) Author: [hidden] (vezjakv) (Tryton translator) Date: 2014-01-19.21:19:53
yes, it is there: c:\users\<username>\.neso\3.0\demo.sqlite.

Similarly, I've installed Windows tryton client and trytond server on
Linux w/ sqlite as backend. Funny thing is that when adding connection profile,
it cannot list sqlite databases on the server, just Create Database. 
But I can connect to the sqlite database if I enter server:port and database 
name directly.
msg15176 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2014-01-19.20:31:09
I can not reproduce it.
Could you verify if the sqlite database are correctly created in
$HOME/.neso/3.0/<name>.sqlite ?
msg15107 (view) Author: [hidden] (vezjakv) (Tryton translator) Date: 2014-01-14.09:38:18
After initial start and new database created,
it works normal in current session.
But after closing neso, and starting again
there is no database list, always 'Create database'
button. There is no option to connect to 
existing database.
History
Date User Action Args
2014-03-04 23:10:41cedsetstatus: testing -> resolved
2014-03-04 23:10:25roundup-botsetnosy: + roundup-bot
messages: + msg15858
2014-03-02 22:33:16pokolisetmessages: + msg15824
2014-03-02 22:15:42cedsetcomponent: + trytond, - neso
2014-03-02 22:15:17cedsetstatus: chatting -> testing
reviews: 3991002
messages: + msg15823
keyword: + review
assignedto: ced
2014-03-02 21:21:32pokolisetmessages: + msg15822
2014-03-02 20:05:22pokolisetstatus: need-eg -> chatting
messages: + msg15821
2014-03-02 19:09:44pokolisetnosy: + pokoli
2014-02-12 16:13:39tkhynsetnosy: + tkhyn
messages: + msg15592
2014-01-29 11:15:14dominiksetmessages: + msg15377

Showing 10 items. Show all history (warning: this could be VERY long)