Tryton - Issues

 

Issue3440

Title client_3.0 on windows: utf8 codec can't decode when entering a letter in Filter Field (German DB)
Priority bug Status resolved
Superseder Nosy List b0r7, ced, resteve
Type crash Components tryton
Assigned To ced Keywords de, win32
Reviews

Created on 2013-10-24.12:46:43 by b0r7, last changed by ced.

Files
File name Uploaded Type Edit Remove
tyton-client-3.0-error-screenshot.fw.png b0r7, 2013-10-24.13:16:37 image/png
Messages
msg14542 (view) Author: [hidden] (resteve) Date: 2013-11-04.23:35:51
Is will include this bug in Tryton 3.0.2 windows package?
msg14449 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2013-10-27.19:25:49
Fixed with rev 2bbb22151fc0
msg14414 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2013-10-25.00:59:08
Please don't change issue status if it is not assigned to you.
msg14413 (view) Author: [hidden] (b0r7) Date: 2013-10-25.00:30:06
yes. thats a fix.
msg14411 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2013-10-25.00:10:04
Please test patch at review1301002
msg14410 (view) Author: [hidden] (b0r7) Date: 2013-10-24.16:12:13
small update: i ran tryton from src in windows7x64 (python.exe tryton) and the
error message is a bit longer.. maybe of help

## console output:
c:\Users\b0r7\Desktop\tryton_src_30\tryton\bin>python tryton
ERROR:tryton.common.common:  File
"c:\Users\bor7\Desktop\tmp_druckstelle\tryton_src_30\tryton\tryton\gui\window\view_form\view\screen_container.py",
line 271, in update
    res = self.screen.search_complete(self.get_text())

  File
"c:\Users\b0r7\Desktop\tryton_src_30\tryton\tryton\gui\window\view_form\screen\screen.py",
line 180, in search_complete
    return list(self.domain_parser.completion(search_string))

  File
"c:\Users\b0r7\Desktop\tryton_src_30\tryton\tryton\common\domain_parser.py",
line 844, in completion
    for complete in self.complete(ending):

  File
"c:\Users\b0r7\Desktop\tryton_src_30\tryton\tryton\common\domain_parser.py",
line 880, in complete
    if field['string'].lower().startswith(name.lower()):

'utf8' codec can't decode bytes in position 11-12: invalid continuation byte
msg14409 (view) Author: [hidden] (b0r7) Date: 2013-10-24.14:13:24
i also ran an instance of the server on debian vm for testing but the server 
output is completely silent.. just the success message of the db connection.. so 
it looks like client code thingy.. 

Another observation: after the error (mentioned) error message the client 
crashes and is unresponsive, meaning: 

- I Click on 'Schlie├čen' (Cancel)
- theres a line added in the Error Output
"File "tryton\gui\window\view_form\view\screen_container.pyc", line 394, in 
focus_in"
- I Click Cancel again. and again and nothing happens
- I terminate the client via Windows Task-Manager
msg14408 (view) Author: [hidden] (b0r7) Date: 2013-10-24.14:07:09
any letter. it seems it doesn't matter, i tested
l (lowercase L), a, 4
msg14406 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2013-10-24.13:55:25
And what are you typing?
msg14404 (view) Author: [hidden] (b0r7) Date: 2013-10-24.13:23:13
i seem to cannot edit my prev. comment but there's a typo: the correct error is: 
Fehler: 'utf8' codec can't decode bytes in position 11-12: invalid continuation 
byte

byte position is 11-12 NOT 11-23
msg14403 (view) Author: [hidden] (b0r7) Date: 2013-10-24.13:16:37
sure, sorry.. i forgot:

Fehler: 'utf8' codec can't decode bytes in position 11-23: invalid continuation 
byte
i attached a screenshot..
msg14402 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2013-10-24.13:04:51
Can we have the full error message?
msg14401 (view) Author: [hidden] (b0r7) Date: 2013-10-24.12:46:42
## Reproduce Steps: 
- install tryton3.0 Client on Win7_x64
- connect do demo.tryton.org
- login with USER: demo_de; PASS: demo
- Click on e.g. 'Parteien/Parteien' 
- Type a letter in the Filter Box

## tested:
demo/demo = works
demo_es = error
demo_de = error

## Error Message: 
File "tryton\gui\window\view_form\view\screen_container.pyc", line 271, in 
update

  File "tryton\gui\window\view_form\screen\screen.pyc", line 180, in 
search_complete

  File "tryton\common\domain_parser.pyc", line 844, in completion

  File "tryton\common\domain_parser.pyc", line 880, in complete

## Maybe this is related:
I downloaded the Client_3.0.exe on a WINXP_32 VM ..
Error: Installer integrity check has failed etc.. more information at: 
http://nsis.sf.net/NSIS_Error
(same with Neso_3.0); 2.8 branch works fine
History
Date User Action Args
2014-04-23 23:07:36cedlinkissue3863 superseder
2014-03-11 21:06:43cedunlinkissue3744 superseder
2014-03-07 21:57:07cedlinkissue3744 superseder
2014-01-24 10:25:31cedlinkissue3616 superseder
2013-12-09 12:33:11cedlinkissue3549 superseder
2013-11-11 03:17:15cedlinkissue3482 superseder
2013-11-05 00:32:44cedsetstatus: chatting -> resolved
2013-11-04 23:35:52restevesetstatus: resolved -> chatting
nosy: + resteve
messages: + msg14542
2013-11-04 23:17:30cedlinkissue3471 superseder
2013-11-04 14:21:05cedlinkissue3468 superseder

Showing 10 items. Show all history (warning: this could be VERY long)