Issue 3348

Title
Skiptest attribute overlaping
Priority
bug
Status
resolved
Nosy list
ced, jcavallo
Assigned to
ced
Keywords

Created on 2013-08-30.12:18:50 by jcavallo, last changed 94 months ago by ced.

Messages

Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2013-09-05.11:59:09
Fixed with rev 5bd1e13ab72d
Author: [hidden] (jcavallo)
Date: 2013-08-30.17:57:49
Looks like it's working !
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2013-08-30.17:40:06
Indeed the patch reveal an other issue in currency module which is fixed by this
patch at review1049003
Author: [hidden] (jcavallo)
Date: 2013-08-30.15:28:41
> Please test patch at review1047003

It looks like it breaks something else.

I am having failures when unittesting base modules (like currency)
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2013-08-30.15:00:05
Please test patch at review1047003
Author: [hidden] (jcavallo)
Date: 2013-08-30.13:21:45
> I can not see what could happen. For me, skip_data is reset after each
> data tag

It only work if self.taghandler is not set. What I noticed is that it is not 
reset between files which leads to skip_data not being removed.

I suppose that since when debugging self.taghandler is set when starting to 
parse the new file, whereas it's None for all other files.
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2013-08-30.13:13:14
On 30/08/13 12:55 +0200, Jean CAVALLO wrote:
> > Did the file2.xml starts with a data tag?
> 
> Yes it does (well tryton => data). It works properly outside unittesting.

I can not see what could happen. For me, skip_data is reset after each
data tag:
http://hg.tryton.org/trytond/file/5236aa254801/trytond/convert.py#l433
Author: [hidden] (jcavallo)
Date: 2013-08-30.12:55:13
> Did the file2.xml starts with a data tag?

Yes it does (well tryton => data). It works properly outside unittesting.
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2013-08-30.12:51:45
Did the file2.xml starts with a data tag?
Author: [hidden] (jcavallo)
Date: 2013-08-30.12:18:50
I noticed the following problem when unitesting views.

In a module, i got two xml files (file1.xml and file2.xml).

file1.xml ends with a <data skiptest="1"> part.

The problem is that file2.xml records are not registered when unittesting. That 
does not lead to a validation failure, which is not really a problem except for 
the fact that the xml is not validated.

However, I got another module depengind on the first one, in which a view 
inherits a view defined in file2. unittesting fails then, as the file2 records 
weren't properly registered.
History
Date User Action Args
2013-09-05 11:59:09cedsetstatus: testing -> resolved
messages: + msg14019
2013-08-30 17:57:50jcavallosetmessages: + msg13972
2013-08-30 17:40:07cedsetmessages: + msg13971
2013-08-30 15:28:42jcavallosetmessages: + msg13969
2013-08-30 15:00:08cedsetstatus: chatting -> testing
assignedto: ced
component: + trytond
messages: + msg13968
2013-08-30 13:21:46jcavallosetmessages: + msg13967
2013-08-30 13:13:14cedsetmessages: + msg13966
2013-08-30 12:55:14jcavallosetmessages: + msg13965
2013-08-30 12:51:45cedsetstatus: unread -> chatting
nosy: + ced
messages: + msg13964
2013-08-30 12:18:50jcavallocreate

Showing 10 items. Show all history (warning: this could be VERY long)