Issue 10745

Title
Promotion is not applied when sale date is empty
Priority
bug
Status
resolved
Nosy list
pokoli, reviewbot, roundup-bot
Assigned to
pokoli
Keywords
backport, review

Created on 2021-09-13.09:46:03 by pokoli, last changed 1 week ago by roundup-bot.

Messages

New changeset ceddc6386d2f by Sergi Almacellas Abellana in branch 'default':
Use today when sale date is empty
https://hg.tryton.org/tryton-env/rev/ceddc6386d2f
New changeset 263a96bd1a3f by Sergi Almacellas Abellana in branch 'default':
Use today when sale date is empty
https://hg.tryton.org/modules/sale_promotion/rev/263a96bd1a3f
Author: [hidden] (pokoli) Tryton committer Tryton translator
Date: 2021-09-13.09:46:03

Steps to reproduce:

  1. Create a promotion with end_date 31/12/2021
  2. Create a sale which applies for the promotion without setting sale date.

Current behaviour:

  • The promotion is not applied

Expected behaviour:

  • The promotion is applied because the promotion is valid for today (which is the date that will be used for sale date when confirming the sale).
History
Date User Action Args
2021-09-17 10:30:26roundup-botsetmessages: + msg70161
2021-09-17 10:30:22roundup-botsetmessages: + msg70160
nosy: + roundup-bot
status: testing -> resolved
2021-09-17 10:13:01pokolisetkeyword: + backport
2021-09-13 09:58:49reviewbotsetmessages: + msg70040
nosy: + reviewbot
2021-09-13 09:47:12pokolisetkeyword: + review
reviews: 371881002
status: in-progress -> testing
2021-09-13 09:46:03pokolicreate

Showing 10 items. Show all history (warning: this could be VERY long)