Issue 10530

Title
Processing a purchase in foreign currency issue.
Priority
bug
Status
resolved
Nosy list
ced, nelghani, reviewbot, roundup-bot
Assigned to
ced
Keywords
review

Created on 2021-06-25.11:00:00 by nelghani, last changed 3 weeks ago by roundup-bot.

Files

File name Uploaded Type Details
ProcessingPurchase_ErrorMessage.jpg nelghani, 2021-06-25.11:00:52 image/jpeg view

Messages

New changeset 0bc880e9003d by Cédric Krier in branch '5.0':
Use parent's line record to set currency and company
https://hg.tryton.org/tryton-env/rev/0bc880e9003d
New changeset 51b44bc4bdbb by Cédric Krier in branch '5.0':
Use parent's line record to set currency and company
https://hg.tryton.org/modules/sale/rev/51b44bc4bdbb
New changeset 9504f4b46275 by Cédric Krier in branch '5.0':
Use parent's line record to set currency and company
https://hg.tryton.org/modules/purchase/rev/9504f4b46275
New changeset 797c6536cfa1 by Cédric Krier in branch '6.0':
Fill currency and company for non-line invoice line
https://hg.tryton.org/modules/sale/rev/797c6536cfa1

New changeset e9ba1b2243f8 by Cédric Krier in branch '5.8':
Fill currency and company for non-line invoice line
https://hg.tryton.org/modules/sale/rev/e9ba1b2243f8

New changeset a17ce1e1c00e by Cédric Krier in branch '5.0':
Fill currency and company for non-line invoice line
https://hg.tryton.org/modules/sale/rev/a17ce1e1c00e
New changeset 64460f8e60df by Cédric Krier in branch '6.0':
Fill currency and company for non-line invoice line
https://hg.tryton.org/modules/purchase/rev/64460f8e60df

New changeset f4740bb36224 by Cédric Krier in branch '5.8':
Fill currency and company for non-line invoice line
https://hg.tryton.org/modules/purchase/rev/f4740bb36224

New changeset ea198fab2227 by Cédric Krier in branch '5.0':
Fill currency and company for non-line invoice line
https://hg.tryton.org/modules/purchase/rev/ea198fab2227
New changeset 1b7dcb2a53d9 by Cédric Krier in branch 'default':
Fill currency and company for non-line invoice line
https://hg.tryton.org/tryton-env/rev/1b7dcb2a53d9
New changeset 6d2027238aca by Cédric Krier in branch 'default':
Fill currency and company for non-line invoice line
https://hg.tryton.org/modules/sale/rev/6d2027238aca
New changeset 026acb245153 by Cédric Krier in branch 'default':
Fill currency and company for non-line invoice line
https://hg.tryton.org/modules/purchase/rev/026acb245153
Author: [hidden] (nelghani)
Date: 2021-10-25.11:05:57

Patch applied and tested on tryton 5.8
No error message and the issue is solved
Regards

Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2021-10-23.01:18:49

This was introduced by issue9854.
Here is review375831002 which should fix it.

Author: [hidden] (nelghani)
Date: 2021-06-25.11:00:00

If a purchase made in a foreign currency contains a line with a title type, a message error is raised when the pruchase is processed.

The value of the field "Lines" in invoice is not valid according ti its domain.

See attached screenhot

This issue occurs in tryton 5.8 and 6.0

regards

History
Date User Action Args
2021-11-04 10:17:24roundup-botsetmessages: + msg71524
2021-11-04 10:17:22roundup-botsetmessages: + msg71523
2021-11-04 10:17:20roundup-botsetmessages: + msg71522
2021-11-02 19:11:54roundup-botsetmessages: + msg71495
2021-11-02 19:11:44roundup-botsetmessages: + msg71493
2021-10-26 19:47:27roundup-botsetmessages: + msg71303
2021-10-26 19:47:22roundup-botsetmessages: + msg71301
2021-10-26 19:47:18roundup-botsetmessages: + msg71299
nosy: + roundup-bot
status: testing -> resolved
2021-10-25 11:05:57nelghanisetmessages: + msg71268
2021-10-23 01:30:38reviewbotsetmessages: + msg71256
nosy: + reviewbot

Showing 10 items. Show all history (warning: this could be VERY long)