Issue 10191

Title
Allow correction of supplier invoice
Priority
feature
Status
resolved
Nosy list
ced, reviewbot, roundup-bot
Assigned to
ced
Keywords
review

Created on 2021-03-12.17:13:07 by ced, last changed 1 month ago by roundup-bot.

Messages

New changeset d643a86c0aeb by Cédric Krier in branch 'default':
Manage price correction from supplier invoice
https://hg.tryton.org/tryton-env/rev/d643a86c0aeb
New changeset 53918955ac8b by Cédric Krier in branch 'default':
Manage price correction from supplier invoice
https://hg.tryton.org/modules/account_invoice_stock/rev/53918955ac8b
New changeset b9487881529a by Cédric Krier in branch 'default':
Manage price correction from supplier invoice
https://hg.tryton.org/modules/account_invoice_correction/rev/b9487881529a
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2021-03-12.17:13:07

It may happen that we receive a correction invoice from a supplier. For the same reason that we do correction for customer invoice, we should do the same for supplier. But the problem is that the design is not suit for the workflow because we may receive from the supplier one credit note to correct multiple invoices etc.
So I think it will be better to have a flag on the supplier invoice line to mark the line as a correction. This way the amount is taken to update the unit price but not the quantity.
This design can not be used for customer invoice because the anglo-saxon accounting will be wrong, we must keep using the account_invoice_correction module.

History
Date User Action Args
2021-03-21 16:08:18roundup-botsetmessages: + msg65727
2021-03-21 16:08:07roundup-botsetmessages: + msg65726
2021-03-21 16:08:04roundup-botsetmessages: + msg65725
nosy: + roundup-bot
status: testing -> resolved
2021-03-12 18:05:43reviewbotsetmessages: + msg65461
nosy: + reviewbot
2021-03-12 17:54:29cedsetkeyword: + review
reviews: 332231002
status: in-progress -> testing
2021-03-12 17:13:07cedcreate

Showing 10 items. Show all history (warning: this could be VERY long)