Issue 10014

Title
Missing ID in pre_validate call
Priority
bug
Status
resolved
Nosy list
2cadz, ced, reviewbot, roundup-bot
Assigned to
ced
Keywords
review

Created on 2021-01-19.17:45:59 by ced, last changed 3 weeks ago by roundup-bot.

Messages

New changeset 534960e706c0 by Cédric Krier in branch '5.8':
Include id as argument of pre_validate calls
https://hg.tryton.org/tryton/rev/534960e706c0

New changeset 3b1589d79e45 by Cédric Krier in branch '5.6':
Include id as argument of pre_validate calls
https://hg.tryton.org/tryton/rev/3b1589d79e45

New changeset 09b75e2f7ef5 by Cédric Krier in branch '5.0':
Include id as argument of pre_validate calls
https://hg.tryton.org/tryton/rev/09b75e2f7ef5
New changeset 036688f25b24 by Cédric Krier in branch '5.8':
Include id as argument of pre_validate calls
https://hg.tryton.org/sao/rev/036688f25b24

New changeset 29fda6e71c16 by Cédric Krier in branch '5.6':
Include id as argument of pre_validate calls
https://hg.tryton.org/sao/rev/29fda6e71c16

New changeset 4f588a70e0bf by Cédric Krier in branch '5.0':
Include id as argument of pre_validate calls
https://hg.tryton.org/sao/rev/4f588a70e0bf
New changeset ae4535aad7b6 by Cédric Krier in branch 'default':
Include id as argument of pre_validate calls
https://hg.tryton.org/tryton-env/rev/ae4535aad7b6
New changeset 2e64570bb195 by Cédric Krier in branch 'default':
Include id as argument of pre_validate calls
https://hg.tryton.org/tryton/rev/2e64570bb195
New changeset 9d89c0c569a8 by Cédric Krier in branch 'default':
Include id as argument of pre_validate calls
https://hg.tryton.org/sao/rev/9d89c0c569a8
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2021-01-19.17:45:59

pre_validate is called with only the values of the modified fields but for saved record, we may need to have other values that were not modified. Those values will be read from the database (as there are not modified) but this is not possible because the call does not provide the id.
The problem can be reproduced by editing a line of advance payment terms (module sale_advance_payment) when closing the popup (and not modify the formula).

History
Date User Action Args
2021-02-11 21:59:05roundup-botsetmessages: + msg64480
2021-02-11 21:58:49roundup-botsetkeyword: - backport
messages: + msg64477
2021-01-29 00:04:56roundup-botsetmessages: + msg64159
2021-01-29 00:04:53roundup-botsetmessages: + msg64158
2021-01-29 00:04:51roundup-botsetmessages: + msg64157
nosy: + roundup-bot
status: testing -> resolved
2021-01-29 00:03:52cedsetkeyword: + backport
2021-01-19 18:14:57reviewbotsetmessages: + msg63985
nosy: + reviewbot
2021-01-19 17:49:11cedsetkeyword: + review
reviews: 327031002
status: in-progress -> testing
2021-01-19 17:45:59cedcreate

Showing 10 items. Show all history (warning: this could be VERY long)