Tryton - Issues

 

Message45501

Author semarie
Recipients ced
Date 2018-12-25.10:10:24
Content
New patch (issue7890-3.patch)
- getter name updated to `get_payment_aggregated`
- label of `amount_succeeded` updated
- all new fields prefixed with `payment_`
- use Sum(..., filter_=...) : I used it only when backend is postgresql: current code in modules uses the same idiom
- uses a method call for the list of states. I think the name could be better ? it is `_get_complete_states` currently
- add conditionals for filling result[], and as here for computes the values (columns of the query are dynamically added depending the fields asked for)
- scenarios extended

New things:
- add a `currency_digits` functional field. as several payment_ fields depends on it, it is better if it is here

Pending question:
- should the state name for `payment_amount_succeeded` be a list and returned by method call ? currently, it is the amount for payment with state `succeeded`. but does a module would be able to extend the semantic to have differents states for "succeeded" ? it could be changed later too.

Tested with tox on py36-{sqlite,postgresql}
Files
File name Uploaded
issue7890-3.patch semarie, 2018-12-25.10:10:24
History
Date User Action Args
2018-12-25 10:10:25semariesetmessageid: <1545729025.2.0.527260134734.issue7890@tryton.org>
2018-12-25 10:10:25semariesetrecipients: + ced
2018-12-25 10:10:25semarielinkissue7890 messages
2018-12-25 10:10:24semariecreate