Tryton - Issues

 

Message45447

Author ced
Recipients semarie
Date 2018-12-21.19:07:44
Content
I do not think the getter name should list all the fields because we will have to change name if we add new one. Maybe get_payment_aggregated.
The label of 'amount_succeeded' should be "Amount Succeeded" or just "Succeeded".
I think it is better to prefix all those field with 'payment_'
Instead of Sum(Case()), it is better to use Sum(..., filter_=...)
Why naming group id 'grid'?
I think SQLite needs also to convert integer result into Boolean.
Still the list of states in the query should be extendable, this means it should come from a method call. And it should be reused in the searcher.
Why not fill directly result like this: result['count'][id_] = count ? Also you can also avoid to fill dict for names that are not requested.
It will be good to extend scenario to test the computation of those field. No need to create more records but just run the methods.
History
Date User Action Args
2018-12-21 19:07:45cedsetmessageid: <1545415665.11.0.482686720004.issue7890@tryton.org>
2018-12-21 19:07:45cedsetrecipients: + semarie
2018-12-21 19:07:45cedlinkissue7890 messages
2018-12-21 19:07:44cedcreate

Showing 10 items. Show all history (warning: this could be VERY long)