Issue 9906

Title
A company is required for updating sequence values
Priority
bug
Status
resolved
Nosy list
ced, pokoli, reviewbot, roundup-bot
Assigned to
ced
Keywords
review

Created on 2020-12-02.20:42:09 by pokoli, last changed 3 weeks ago by roundup-bot.

Messages

New changeset 0e79561db204 by Cédric Krier in branch '5.8':
Do not return None when evaluating domain with in operator
https://hg.tryton.org/trytond/rev/0e79561db204
New changeset c51a816b59a7 by Cédric Krier in branch '5.8':
Do not return None when evaluating domain with in operator
https://hg.tryton.org/tryton/rev/c51a816b59a7
New changeset c6c98fba1000 by Cédric Krier in branch '5.8':
Do not return None when evaluating domain with in operator
https://hg.tryton.org/sao/rev/c6c98fba1000
New changeset 4a6d9a302e75 by Cédric Krier in branch 'default':
Do not return None when evaluating domain with in operator
https://hg.tryton.org/tryton-env/rev/4a6d9a302e75
New changeset 3618ad48af99 by Cédric Krier in branch 'default':
Do not return None when evaluating domain with in operator
https://hg.tryton.org/trytond/rev/3618ad48af99
New changeset 5850f1210e5d by Cédric Krier in branch 'default':
Do not return None when evaluating domain with in operator
https://hg.tryton.org/tryton/rev/5850f1210e5d
New changeset 03aa192c5c2b by Cédric Krier in branch 'default':
Do not return None when evaluating domain with in operator
https://hg.tryton.org/sao/rev/03aa192c5c2b
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2021-03-11.23:47:26
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2020-12-02.21:29:28

I think it is because the domain inversion does not evaluate correctly the ('company', 'in', […, None]).
I think rev 57e0e3a871c1 need also to manage None with in operator like in Field._domain_add_null.

Author: [hidden] (pokoli) Tryton committer Tryton translator
Date: 2020-12-02.20:42:09

On 5.8 series if you try to update the values of a sequence from the configuration singleton the company field is required (from domain inversion) but it should be optional to allow sharing the same sequence between multiple companies.

Steps to reproduce (tested on demo server):

  1. Login with admin user
    2
    . Open the sale configuracion (Sale -> Configuration -> Sale Configuration)
  2. Open the Sale Sequence and change the number.

Current result:

  • The client complaints about a required value for company

Expected behaviour:

The number can be changed without altering the view.

As a workarround, it is possible to update the sequences from the Administration -> Sequences -> Sequences menu.

History
Date User Action Args
2021-04-10 01:44:53roundup-botsetmessages: + msg66274
2021-04-10 01:44:46roundup-botsetmessages: + msg66272
2021-04-10 01:44:40roundup-botsetkeyword: - backport
messages: + msg66270
2021-03-20 12:33:46roundup-botsetmessages: + msg65696
2021-03-20 12:33:38roundup-botsetmessages: + msg65695
2021-03-20 12:33:33roundup-botsetmessages: + msg65694
2021-03-20 12:33:30roundup-botsetmessages: + msg65693
nosy: + roundup-bot
status: testing -> resolved
2021-03-12 00:13:12reviewbotsetmessages: + msg65431
nosy: + reviewbot
2021-03-11 23:47:26cedsetassignedto: ced
keyword: + backport, review
messages: + msg65430
reviews: 332201005
status: chatting -> testing
2020-12-02 21:29:28cedsetmessages: + msg62346
nosy: + ced
status: unread -> chatting

Showing 10 items. Show all history (warning: this could be VERY long)