Issue 9646

Title
Application Error on Payment Groups view
Priority
bug
Status
resolved
Nosy list
ced, reviewbot, roundup-bot, srgdts
Assigned to
srgdts
Keywords
review

Created on 2020-09-28.21:26:12 by srgdts, last changed 4 days ago by roundup-bot.

Messages

New changeset 1fa8358d57f6 by C├ędric Krier in branch 'default':
Re-add workflow decorator to process method
https://hg.tryton.org/tryton-env/rev/1fa8358d57f6
New changeset a431d30e9a5b by Sergey Datsevich in branch 'default':
Re-add workflow decorator to process method
https://hg.tryton.org/modules/account_payment/rev/a431d30e9a5b
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2020-09-28.22:40:49
I think the best is to re-add the workflow decorator to the process method.
Author: [hidden] (srgdts)
Date: 2020-09-28.21:26:11
ERROR:trytond.protocols.dispatcher:<class 'trytond.modules.account_payment.payment.Group'>.read(*([4, 5], ....

Traceback (most recent call last):
  File "/home/hermes/devel/tryton/trytond/trytond/protocols/dispatcher.py", line 181, in _dispatch
    result = rpc.result(meth(*c_args, **c_kwargs))
  File "/home/hermes/devel/tryton/trytond/trytond/model/modelsql.py", line 861, in read
    row[fname] = getter_result[row['id']]
KeyError: 4


The payments are not filtered in Payment.process(payments, group). A new group is created on each invocation of Payment.process(payments, group).

Trunk is affected.
Caused by: issue9525

Steps to reproduce:
1) Create a payment (at least the manual process method affected)
2) Call Process Payments Wizard on the payment *multiple* times
3) Reload the Payment Group view created by Wizard at the end
4) An Application Error appears
History
Date User Action Args
2020-10-22 00:03:29roundup-botsetmessages: + msg61144
2020-10-22 00:03:24roundup-botsetmessages: + msg61143
nosy: + roundup-bot
status: testing -> resolved
2020-09-29 12:12:31srgdtssetassignedto: srgdts
2020-09-29 00:56:55reviewbotsetnosy: + reviewbot
messages: + msg60458
2020-09-29 00:23:27srgdtssetstatus: chatting -> testing
2020-09-29 00:21:20srgdtssetreviews: 298681004
keyword: + review
2020-09-28 22:40:49cedsetstatus: unread -> chatting
nosy: + ced
messages: + msg60455
2020-09-28 21:26:12srgdtscreate

Showing 10 items. Show all history (warning: this could be VERY long)