Issue 9618

Title
Selection field value is cleared when creating a new row
Priority
bug
Status
resolved
Superseder
Tryton keeps a reference to unused Combobox in editable trees (issue 9266)
Nosy list
Timitos, ced, pokoli, reviewbot, roundup-bot
Assigned to
ced
Keywords
backport, review

Created on 2020-09-18.17:12:58 by pokoli, last changed 4 days ago by roundup-bot.

Files

File name Uploaded Type Details
2020-09-18 14-19-06.mkv pokoli, 2020-09-18.17:12:58 video/x-matroska view

Messages

New changeset c53a174a9321 by Cédric Krier in branch 'default':
Use editable path to update editable on display
https://hg.tryton.org/tryton-env/rev/c53a174a9321
New changeset 07b4d22509fc by Cédric Krier in branch 'default':
Use editable path to update editable on display
https://hg.tryton.org/tryton/rev/07b4d22509fc
Author: [hidden] (Timitos) Tryton translator
Date: 2020-10-16.16:28:21
works for me
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2020-10-16.11:39:26
Here is review314471002 which solves the issue by not using current record but relying on the path of the editable.
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2020-10-16.09:46:06
This is since issue9227 and indeed it is a side effect of issue9266.
Author: [hidden] (pokoli) Tryton committer Tryton translator
Date: 2020-09-18.17:12:58
We have a custom module that adds a new selection field on the contact mechanism tree view. This field has an empty value. The value of this field is cleared when creating a new row because tryton client sets the default value of the new record in the previous selected record. 

I attach a video that ilustrates the problem. 

We've found the problem on 5.0 series but the bug is already reproducible on trunk version
History
Date User Action Args
2020-10-21 23:21:53roundup-botsetmessages: + msg61130
2020-10-21 23:21:50roundup-botsetmessages: + msg61128
nosy: + roundup-bot
status: testing -> resolved
2020-10-16 16:28:21Timitossetnosy: + Timitos
messages: + msg60994
2020-10-16 12:06:07reviewbotsetmessages: + msg60986
2020-10-16 11:39:26cedsetreviews: 292251002 -> 292251002,314471002
assignedto: pokoli -> ced
messages: + msg60984
2020-10-16 09:46:06cedsetmessages: + msg60981
superseder: + Tryton keeps a reference to unused Combobox in editable trees
nosy: + ced
2020-09-18 17:18:10reviewbotsetnosy: + reviewbot
messages: + msg60235
2020-09-18 17:16:20pokolisetstatus: in-progress -> testing
reviews: 292251002
keyword: + review
2020-09-18 17:12:58pokolicreate

Showing 10 items. Show all history (warning: this could be VERY long)