Tryton - Issues

 

Issue9419

Title Calendar events do not show its title
Priority bug Status resolved
Superseder Nosy List pokoli, reviewbot, roundup-bot
Type behavior Components sao
Assigned To pokoli Keywords review
Reviews 313811002
View: 313811002

Created on 2020-06-16.11:08:10 by pokoli, last changed by roundup-bot.

Files
File name Uploaded Type Edit Remove
Screenshot_2020-06-16 Productions - Tryton(1).png pokoli, 2020-06-16.11:08:09 image/png
Messages
New changeset e2ffcad43695 by Sergi Almacellas Abellana in branch '5.6':
Append event description using a span attribute
https://hg.tryton.org/sao/rev/e2ffcad43695

New changeset de41129ae812 by Sergi Almacellas Abellana in branch '5.2':
Append event description using a span attribute
https://hg.tryton.org/sao/rev/de41129ae812

New changeset ca53dca8f37e by Sergi Almacellas Abellana in branch '5.4':
Append event description using a span attribute
https://hg.tryton.org/sao/rev/ca53dca8f37e

New changeset 8d59523e07e7 by Sergi Almacellas Abellana in branch '5.0':
Append event description using a span attribute
https://hg.tryton.org/sao/rev/8d59523e07e7
New changeset b3f297c709ea by Sergi Almacellas Abellana in branch 'default':
Append event description using a span attribute
https://hg.tryton.org/tryton-env/rev/b3f297c709ea
New changeset a2ad5377ec11 by Sergi Almacellas Abellana in branch 'default':
Append event description using a span attribute
https://hg.tryton.org/sao/rev/a2ad5377ec11
review313811002 updated at https://codereview.tryton.org/313811002/#ps313801005
review313811002 updated at https://codereview.tryton.org/313811002/#ps309861011
New review313811002 at https://codereview.tryton.org/313811002/#ps313801004
msg58724 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2020-06-16.11:30:34
Indeed the problem was introduced with rev 2d55ed2f2bb1 which used text for event description and removed the title.

Here is review313811002 which fixes it.
msg58723 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2020-06-16.11:08:44
It is possible to fix it by including all the fields on the description and not setting the title attribute. But I'm not sure if it's the best solution.
msg58722 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2020-06-16.11:08:09
It can be reproduced on demo server by creating a new production without product 
nor reference. 

The event is shown with empty text (see screenshoot) but it should render the production number
History
Date User Action Args
2020-07-10 23:29:44roundup-botsetmessages: + msg59265
keyword: - backport
2020-07-04 19:58:11roundup-botsetmessages: + msg58969
2020-07-04 19:58:07roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg58968
2020-07-04 19:55:55pokolisetkeyword: + backport
2020-06-16 13:58:33reviewbotsetmessages: + msg58727
2020-06-16 13:03:15reviewbotsetmessages: + msg58726
2020-06-16 11:37:42reviewbotsetnosy: + reviewbot
messages: + msg58725
2020-06-16 11:37:39reviewbotsetreviews: 313811002
keyword: + review
2020-06-16 11:30:34pokolisetstatus: chatting -> testing
assignedto: pokoli
messages: + msg58724
title: Calendar events do not show it's title -> Calendar events do not show its title
2020-06-16 11:08:45pokolisetstatus: unread -> chatting
messages: + msg58723

Showing 10 items. Show all history (warning: this could be VERY long)