Issue 9417

Title
Work state is not updated after the production is done
Priority
bug
Status
resolved
Nosy list
ced, pokoli, reviewbot, roundup-bot
Assigned to
pokoli
Keywords
review

Created on 2020-06-15.16:14:12 by pokoli, last changed 4 months ago by roundup-bot.

Messages

New changeset 02898d622600 by Sergi Almacellas Abellana in branch '5.6':
Update work state when a production is done
https://hg.tryton.org/modules/production_work/rev/02898d622600

New changeset b7d6a3cfb8c6 by Sergi Almacellas Abellana in branch '5.4':
Update work state when a production is done
https://hg.tryton.org/modules/production_work/rev/b7d6a3cfb8c6

New changeset 6f70b2e3293f by Sergi Almacellas Abellana in branch '5.0':
Update work state when a production is done
https://hg.tryton.org/modules/production_work/rev/6f70b2e3293f
New changeset 90c4c1ead690 by Sergi Almacellas Abellana in branch 'default':
Update work state when a production is done
https://hg.tryton.org/tryton-env/rev/90c4c1ead690
New changeset cc81b1fef359 by Sergi Almacellas Abellana in branch 'default':
Update work state when a production is done
https://hg.tryton.org/modules/production_work/rev/cc81b1fef359

New changeset 9da24b313d9b by Sergi Almacellas Abellana in branch 'default':
Test work state is done when production is done
https://hg.tryton.org/modules/production_work/rev/9da24b313d9b
Author: [hidden] (pokoli) Tryton committer Tryton translator
Date: 2020-06-15.16:41:53
Yes, what you say is completly valid. My issue is after the production is done. 

Current behaviour is that the works are in 'finished'. But the _state is 'done' when the production is finished. 

The problem is that the work state is never updated when the production is done, so all the works are still in finished state which allows the user to create a new cycle for them (which for me is not correct). Then the work is state is updated to done but there is an active cycle on it. 

So I think the right behaviour is to set all the works to done once the production is done and do not allow to create new cycles.
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2020-06-15.16:24:56
For me, it is not possible to "done" a production order if there are none finished works. And I think it is the proper way to enforce finishing work before the production.
Author: [hidden] (pokoli) Tryton committer Tryton translator
Date: 2020-06-15.16:14:10
Once the production is done it's related works should be updated to done so it is no longer possible to create more cycles for it. 

Currently the works are keep as finished.
History
Date User Action Args
2020-07-30 00:07:23roundup-botsetmessages: + msg59549
keyword: - backport
2020-07-22 08:58:44cedsetkeyword: + backport
2020-07-22 08:51:50roundup-botsetmessages: + msg59429
2020-07-22 08:51:35roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg59428
2020-07-07 13:45:50reviewbotsetmessages: + msg59038
2020-07-04 20:10:18reviewbotsetmessages: + msg58975
2020-06-15 16:41:54pokolisetmessages: + msg58715
2020-06-15 16:33:14reviewbotsetnosy: + reviewbot
messages: + msg58714
2020-06-15 16:33:11reviewbotsetreviews: 307821002
keyword: + review
2020-06-15 16:24:57cedsetnosy: + ced
messages: + msg58713

Showing 10 items. Show all history (warning: this could be VERY long)