Issue 9373

Title
Disable nagle on tcp socket
Priority
feature
Status
invalid
Nosy list
ced, reviewbot
Assigned to
ced
Keywords
review

Created on 2020-05-28.01:11:49 by ced, last changed 4 months ago by ced.

Messages

Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2020-05-28.11:39:50
Finally, I think we should not activate NODELAY after reading https://eklitzke.org/the-caveats-of-tcp-nodelay
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2020-05-28.01:14:09
Here is review323421002

I'm wondering if we should also activate it on the docker images. The problem is that if we do it with '--tcp-nodelay', it will not be possible to deactivate it.
Author: [hidden] (ced) Tryton committer Tryton translator
Date: 2020-05-28.01:11:48
Following: https://discuss.tryton.org/t/huge-delay-running-on-openbsd/2785

Before the migration to werkzeug, we used to set TCP_NODELAY. I think we could set it back using a custom handler with disable_nagle_algorithm set to True.
History
Date User Action Args
2020-05-30 10:12:49cedsetstatus: testing -> invalid
2020-05-28 11:39:50cedsetmessages: + msg58340
2020-05-28 01:31:49reviewbotsetnosy: + reviewbot
messages: + msg58338
2020-05-28 01:14:10cedsetstatus: in-progress -> testing
reviews: 323421002
messages: + msg58337
keyword: + review
2020-05-28 01:11:49cedcreate

Showing 10 items. Show all history (warning: this could be VERY long)