Issue 9212

Title
Duplicated results when changing unit prices
Priority
bug
Status
resolved
Nosy list
pokoli, reviewbot, roundup-bot
Assigned to
pokoli
Keywords
review

Created on 2020-04-05.21:55:44 by pokoli, last changed 18 months ago by roundup-bot.

Messages

New changeset 22abfffb95b5 by Sergi Almacellas Abellana in branch '5.4':
Do not trigger trigger another on_change after setting it's result
https://hg.tryton.org/sao/rev/22abfffb95b5

New changeset 7dd5ec6e7abe by Sergi Almacellas Abellana in branch '5.2':
Do not trigger trigger another on_change after setting it's result
https://hg.tryton.org/sao/rev/7dd5ec6e7abe

New changeset e7459d0d7127 by Sergi Almacellas Abellana in branch '5.0':
Do not trigger trigger another on_change after setting it's result
https://hg.tryton.org/sao/rev/e7459d0d7127
New changeset 57b1c6cc208e by Sergi Almacellas Abellana in branch 'default':
Do not trigger trigger another on_change after setting it's result
https://hg.tryton.org/tryton-env/rev/57b1c6cc208e
New changeset 0e779982f8ba by Sergi Almacellas Abellana in branch 'default':
Do not trigger trigger another on_change after setting it's result
https://hg.tryton.org/sao/rev/0e779982f8ba
Author: [hidden] (pokoli) Tryton committer Tryton translator
Date: 2020-04-15.19:24:58
I've just found the problem. The issue is that sao triggers another on_change after setting the on_change value on which the server answers another line to be added so it is duplicated. 

So here is review311331002 which mimics tryton code to not trigger the duplicated call to the server
Author: [hidden] (pokoli) Tryton committer Tryton translator
Date: 2020-04-05.21:58:24
I've just tested with issue4140 and the issue is fixed for tryton but not for sao.
Author: [hidden] (pokoli) Tryton committer Tryton translator
Date: 2020-04-05.21:55:43
While testing issue9211 i've just realized that lines are duplicated when changing unit price. 

Here are the steps to reproduce:

1. Open the test tax wizard.
2. Set a quantity and unit price and a taxes
3. After the result is shown, update the unit price

Expected behaviour:

- A single tax result is shown

Current behaviour:

- The result is duplicated
History
Date User Action Args
2020-04-25 12:56:07roundup-botsetmessages: + msg57469
keyword: - backport
2020-04-19 13:12:12roundup-botsetmessages: + msg57296
2020-04-19 13:12:09roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg57295
2020-04-19 11:36:12cedsetkeyword: + backport
2020-04-18 13:06:05reviewbotsetmessages: + msg57262
2020-04-15 19:40:14reviewbotsetnosy: + reviewbot
messages: + msg57187
2020-04-15 19:24:58pokolisetstatus: chatting -> testing
keyword: + review
messages: + msg57186
component: + sao
reviews: 311331002
assignedto: pokoli
2020-04-05 21:58:25pokolisetstatus: unread -> chatting
messages: + msg56907
2020-04-05 21:55:44pokolicreate

Showing 10 items. Show all history (warning: this could be VERY long)