Tryton - Issues

 

Issue9175

Title Add try-loop on report convert with soffice
Priority bug Status resolved
Superseder Nosy List Timitos, ced, pokoli, reviewbot, roundup-bot
Type feature request Components trytond
Assigned To ced Keywords easy, review
Reviews 278911002
View: 278911002

Created on 2020-03-24.01:07:37 by ced, last changed by roundup-bot.

Messages
New changeset 1a444192863b by Cédric Krier in branch 'default':
Add retry option to report convert
https://hg.tryton.org/tryton-env/rev/1a444192863b
New changeset 852e50ac7da3 by Cédric Krier in branch 'default':
Add retry option to report convert
https://hg.tryton.org/trytond/rev/852e50ac7da3
msg56827 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2020-04-01.22:05:27
I'm not comfortable by backporting API changes even if it may be transparent.
msg56644 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2020-03-25.17:15:25
As far as the change includes a default value for the new parameter (which does not require any update for current modules) I do not see any issue with backporting it.
msg56643 (view) Author: [hidden] (Timitos) (Tryton translator) Date: 2020-03-25.16:43:23
Wouldn't it be good to make the number of retries a config value? Like it is for database transaction retries?
review278911002 updated at https://codereview.tryton.org/278911002/#ps303181002
msg56641 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2020-03-25.15:34:16
Here is review278911002. I opted for a parameter (instead of an option) because I think we may want to customize report by report (some are more important than others). Because of this, I do not know if we could backport as it changes the API.
msg56607 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2020-03-24.01:07:36
We see a little bit too often conversion error with soffice headless.
This seems to be linked to available resource even if it is not always reproducible. I think this is due to the complex nature of soffice.
Any way, I think before skip conversion, we should try some tries before like we do for database operational issue.
I think if the changes are not too complicated, we should backport as it will improve reliability.
History
Date User Action Args
2020-04-01 23:52:35roundup-botsetmessages: + msg56829
2020-04-01 23:52:30roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg56828
2020-04-01 22:05:28cedsetmessages: + msg56827
keyword: - backport
2020-03-25 17:15:26pokolisetnosy: + pokoli
messages: + msg56644
2020-03-25 16:43:24Timitossetnosy: + Timitos
messages: + msg56643
2020-03-25 15:58:42reviewbotsetnosy: + reviewbot
messages: + msg56642
2020-03-25 15:34:16cedsetstatus: unread -> testing
reviews: 278911002
messages: + msg56641
keyword: + review
assignedto: ced
2020-03-24 01:07:37cedcreate

Showing 10 items. Show all history (warning: this could be VERY long)