Tryton - Issues

 

Issue9014

Title Test fails on series 5.0 and Python 3.4 because of lxml
Priority bug Status resolved
Superseder Nosy List ced, reviewbot
Type crash Components account_statement_ofx, stock_package_shipping_dpd
Assigned To ced Keywords review
Reviews 272981005, 273001002
View: 272981005, 273001002

Created on 2020-01-24.00:38:15 by ced, last changed by ced.

Messages
New review273001002 at https://codereview.tryton.org/273001002/#ps284961002
msg56036 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2020-03-04.09:57:42
Fails also for: https://drone.tryton.org/tryton/modules.stock_package_shipping_dpd/11
review272981005 updated at https://codereview.tryton.org/272981005/#ps250861005
review272981005 updated at https://codereview.tryton.org/272981005/#ps268991038
msg56016 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2020-03-03.00:11:45
Indeed it is linked to issue8553. The problem is the lxml-4.4.0 published which does not have proper python_requires.
msg55030 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2020-01-24.00:38:14
See https://drone.tryton.org/tryton/modules.account_statement_ofx/10/10

It seems that pip select an incompatible version for lxml.
It is strange because on other module, the proper lxml version is selected. It seems that it is because lxml is installed as a dependency of ofxparse.
History
Date User Action Args
2020-03-06 23:24:23cedsetstatus: testing -> resolved
2020-03-04 10:23:31reviewbotsetmessages: + msg56037
2020-03-04 10:23:28reviewbotsetreviews: 272981005 -> 272981005, 273001002
2020-03-04 09:57:42cedsetcomponent: + stock_package_shipping_dpd
messages: + msg56036
2020-03-03 01:00:20reviewbotsetmessages: + msg56018
2020-03-03 00:32:57reviewbotsetnosy: + reviewbot
messages: + msg56017
2020-03-03 00:15:28cedsetstatus: chatting -> testing
reviews: 272981005
keyword: + review
assignedto: ced
2020-03-03 00:11:46cedsetstatus: unread -> chatting
messages: + msg56016
2020-01-24 00:38:15cedcreate

Showing 10 items. Show all history (warning: this could be VERY long)