Tryton - Issues

 

Issue8977

Title Duplicate tabs when open a calendar view with searc_value
Priority bug Status resolved
Superseder Nosy List ced, resteve, reviewbot, roundup-bot
Type behavior Components sao, tryton
Assigned To ced Keywords review
Reviews 272751003
View: 272751003

Created on 2020-01-09.15:37:55 by resteve, last changed by roundup-bot.

Files
File name Uploaded Type Edit Remove
sao-tab-search_value.jpg resteve, 2020-01-09.15:37:54 image/jpeg
Messages
New changeset deb519b8c92a by Cédric Krier in branch '5.4':
Remove id from screen context and compare proper attributes
https://hg.tryton.org/sao/rev/deb519b8c92a

New changeset 622699bc9fd6 by Cédric Krier in branch '5.2':
Remove id from screen context and compare proper attributes
https://hg.tryton.org/sao/rev/622699bc9fd6

New changeset 7a9906846318 by Cédric Krier in branch '5.0':
Remove id from screen context and compare proper attributes
https://hg.tryton.org/sao/rev/7a9906846318
New changeset c2f096c46ca9 by Cédric Krier in branch 'default':
Remove id from screen context and compare proper attributes
https://hg.tryton.org/tryton-env/rev/c2f096c46ca9
New changeset 70cdf0ef43d7 by Cédric Krier in branch 'default':
Remove id from screen context and compare proper attributes
https://hg.tryton.org/tryton/rev/70cdf0ef43d7
New changeset 0ded36c93351 by Cédric Krier in branch 'default':
Remove id from screen context and compare proper attributes
https://hg.tryton.org/sao/rev/0ded36c93351
review272751003 updated at https://codereview.tryton.org/272751003/#ps268721002
msg54809 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2020-01-10.19:20:05
Here is review272751003 that improve the tab comparison and avoid infinite loop caused by the model context id.
msg54775 (view) Author: [hidden] (resteve) Date: 2020-01-09.15:37:54
Action window:

        <record model="ir.action.act_window" id="act_activity_calendar">
            <field name="name">Activities</field>
            <field name="res_model">activity.activity</field>
            <field name="context_model">activity.calendar.context</field>
            <field name="search_value" eval="[('employee', 'ilike', Eval('context', {}).get('employee.rec_name', '%'))]" pyson="1"/>
        </record>

The user has an employee in the preferences.

When open the menu "Activities" (act_activity_calendar), open infinite tabs... (see the screenshot).
History
Date User Action Args
2020-01-27 19:29:36roundup-botsetmessages: + msg55083
keyword: - backport
2020-01-20 11:11:11roundup-botsetmessages: + msg54917
2020-01-20 11:11:08roundup-botsetmessages: + msg54916
2020-01-20 11:11:06roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg54915
2020-01-20 11:09:59cedsetkeyword: + backport
2020-01-10 19:26:20reviewbotsetnosy: + reviewbot
messages: + msg54810
2020-01-10 19:20:05cedsetstatus: in-progress -> testing
reviews: 272751003
component: + tryton
messages: + msg54809
keyword: + review
2020-01-10 17:40:53cedsetstatus: chatting -> in-progress
assignedto: ced
nosy: + ced
2020-01-09 15:37:55restevecreate

Showing 10 items. Show all history (warning: this could be VERY long)