Tryton - Issues

 

Issue8705

Title Random translations
Priority bug Status resolved
Superseder Nosy List Timitos, angel, ced, pokoli, reviewbot, roundup-bot, semarie
Type behavior Components trytond
Assigned To ced Keywords review
Reviews 260271002
View: 260271002

Created on 2019-10-03.14:38:43 by ced, last changed by roundup-bot.

Messages
New changeset 78875434b37e by Cédric Krier in branch '5.2':
Always use search method on translations
https://hg.tryton.org/trytond/rev/78875434b37e
msg52586 (view) Author: [hidden] (pokoli) (Tryton committer) (Tryton translator) Date: 2019-10-21.09:48:22
Please open a new issue with your bug report.
msg52585 (view) Author: [hidden] (semarie) Date: 2019-10-21.09:36:13
I have a regression with it on tip. Some translated strings aren't considered any more.

My database is french, and some fields aren't translated anymore (for example "field:account.statement,start_balance:") whereas the entry is present under Administration > Localisation > Translation view.

If I backout the commit, strings are translated
New changeset 0f7ee9c6027b by Cédric Krier in branch 'default':
Always use search method on translations
https://hg.tryton.org/tryton-env/rev/0f7ee9c6027b
New changeset bfc90c50b591 by Cédric Krier in branch 'default':
Always use search method on translations
https://hg.tryton.org/trytond/rev/bfc90c50b591
review260271002 updated at https://codereview.tryton.org/260271002/#ps260291002
msg52333 (view) Author: [hidden] (angel) Date: 2019-10-08.09:56:22
works with:
https://codereview.tryton.org/260271002/diff/264361002/trytond/ir/translation.py#newcode569
review260271002 updated at https://codereview.tryton.org/260271002/#ps264361002
msg52271 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-10-03.14:38:42
Since issue8034 where we removed the unique constraint on the translations, we can have random result if there are many records for the same translation.
I think it will be counter performant to try to avoid duplicates without using a unique constraint. For me, the best solution is to make selection of the translation record deterministic.
History
Date User Action Args
2019-10-31 00:01:27roundup-botsetmessages: + msg52824
keyword: - backport
2019-10-21 09:48:22pokolisetstatus: chatting -> resolved
nosy: + pokoli
messages: + msg52586
2019-10-21 09:38:29Timitossetnosy: + Timitos
2019-10-21 09:36:14semariesetstatus: resolved -> chatting
nosy: + semarie
messages: + msg52585
2019-10-16 21:31:48roundup-botsetmessages: + msg52529
2019-10-16 21:31:45roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg52528
2019-10-16 21:31:40cedsetkeyword: + backport
2019-10-10 15:09:19reviewbotsetmessages: + msg52381
2019-10-08 09:56:22angelsetnosy: + angel
messages: + msg52333
2019-10-03 15:14:16reviewbotsetnosy: + reviewbot
messages: + msg52272

Showing 10 items. Show all history (warning: this could be VERY long)