Tryton - Issues

 

Issue8629

Title Unsynchronize date between move and line
Priority bug Status resolved
Superseder Nosy List ced, reviewbot, roundup-bot
Type behavior Components account
Assigned To ced Keywords review
Reviews 267891002
View: 267891002

Created on 2019-08-30.17:51:38 by ced, last changed by roundup-bot.

Messages
New changeset fd3bd7f805bd by Cédric Krier in branch 'default':
Update the date of move lines when the date on move is changed
https://hg.tryton.org/tryton-env/rev/fd3bd7f805bd
New changeset 54ee0751982b by Cédric Krier in branch 'default':
Update the date of move lines when the date on move is changed
https://hg.tryton.org/modules/account/rev/54ee0751982b
review267891002 updated at https://codereview.tryton.org/267891002/#ps265951002
review267891002 updated at https://codereview.tryton.org/267891002/#ps262051003
msg51593 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-08-30.17:51:37
The line has a function field with a setter for the date which duplicate the date of the move. The problem is that if lines already exists and the date on the move is changed, the client may try to save a date for the move and another for the line. This may create conflict with the period or have an unpredictable behavior for the user (if the dates are both compatible with the period) as the date of the last line will be actually stored.
History
Date User Action Args
2019-09-12 22:47:26roundup-botsetmessages: + msg51820
2019-09-12 22:47:20roundup-botsetstatus: testing -> resolved
nosy: + roundup-bot
messages: + msg51819
2019-09-02 18:32:12reviewbotsetmessages: + msg51637
2019-08-30 18:03:26reviewbotsetnosy: + reviewbot
messages: + msg51594
2019-08-30 17:52:42cedsetstatus: in-progress -> testing
reviews: 267891002
keyword: + review
2019-08-30 17:51:38cedcreate

Showing 10 items. Show all history (warning: this could be VERY long)