Tryton - Issues

 

Issue8589

Title Tryton 4.8.18 Crash OSX
Priority bug Status resolved
Superseder Nosy List ced, vferraro
Type crash Components
Assigned To ced Keywords macOS
Reviews

Created on 2019-08-20.13:48:30 by vferraro, last changed by ced.

Messages
msg51996 (view) Author: [hidden] (vferraro) Date: 2019-09-21.20:34:26
now works!
msg51995 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-09-21.14:27:03
Could you report if it works for you now: http://downloads.tryton.org/4.8/tryton-last.dmg
msg51993 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-09-21.02:52:32
New versions uploaded.
msg51992 (view) Author: [hidden] (vferraro) Date: 2019-09-20.22:26:20
Osx Mojave

⁣Ing.Vincenzo Ferraro
Research & Technological Consultant
M. +39 371 378 4945
E. vincenzo.ferraro@simpool.it

Simpool Srl
Viale Colleoni, 23
20864 Agrate Brianza (MB)
T. +39 039 96 31 230
F. +39 039 96 31 210
E. info@simpool.it​

Il giorno 20 Set 2019, 18:25, alle ore 18:25, "Cédric Krier" <bugs@tryton.org> ha scritto:
>
>Cédric Krier <cedric.krier@b2ck.com> added the comment:
>
>Which version of OSX?
>
>----------
>nosy: +ced
>status: unread -> need-eg
>
>______________________________________
>Tryton issue tracker <bugs@tryton.org>
><https://bugs.tryton.org/issue8589>
>______________________________________
msg51991 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-09-20.19:24:04
I could reproduce the problem on all latest build.
I could rebuild a working client by cleaning the build and dist directory. I think it is due to some upgrade and some remaining old libraries in the build process.
I'm rebuilding all series right now and I will publish them ASAP.
msg51989 (view) Author: [hidden] (ced) (Tryton committer) (Tryton translator) Date: 2019-09-20.18:25:01
Which version of OSX?
msg51373 (view) Author: [hidden] (vferraro) Date: 2019-08-20.13:48:29
Detail crash:

Traceback (most recent call last):
  File "/usr/local/lib/python2.7/site-packages/cx_Freeze/initscripts/__startup__.py", line 14, in run
  File "/usr/local/lib/python2.7/site-packages/cx_Freeze/initscripts/Console.py", line 26, in run
  File "bin/tryton", line 48, in <module>
    
  File "/Users/ced/4.8/tryton/tryton/client.py", line 17, in <module>
  File "/usr/local/lib/python2.7/site-packages/gi/__init__.py", line 42, in <module>
ImportError: dlopen(/Applications/Tryton.app/Contents/MacOS/lib/gi/_gi.so, 2): Symbol not found: _iconv
  Referenced from: /Applications/Tryton.app/Contents/MacOS/libintl.8.dylib
  Expected in: /Applications/Tryton.app/Contents/MacOS/libiconv.2.dylib
 in /Applications/Tryton.app/Contents/MacOS/libintl.8.dylib
History
Date User Action Args
2019-09-21 20:38:25cedsetstatus: testing -> resolved
2019-09-21 20:34:28vferrarosetmessages: + msg51996
2019-09-21 14:27:03cedsetmessages: + msg51995
2019-09-21 02:52:32cedsetstatus: in-progress -> testing
messages: + msg51993
2019-09-20 22:26:21vferrarosetmessages: + msg51992
2019-09-20 19:24:05cedsetstatus: need-eg -> in-progress
assignedto: ced
messages: + msg51991
keyword: + macOS
2019-09-20 18:25:01cedsetstatus: unread -> need-eg
nosy: + ced
messages: + msg51989
2019-08-28 11:50:39vferrarosettype: crash
2019-08-20 13:48:30vferrarocreate